PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!

Home PS4 News - Latest PlayStation 4 and PS3 News

175w ago - This weekend PlayStation 3 homebrew developer Redsquirrel87 has updated Showtime PS3 Media Player Repack to version 3.3.344, which includes the following changes as detailed below:

Download: PS3 Showtime Media Player Repack v3.3.344

PS3 Showtime Media Player Repack v3.3.344 Changelog:

  • Keep audio pipeline full even if audio is turned off (during video playback)
  • Fix crash
  • ps3: Correct identification of mounted optical drives (names and icon)
  • videoplayback: If we get an error during playback wait until buffers are empty before we exit.
  • Update Slovenian translation
  • blobcache: Fix a bunch of bugs
  • Add missing file (md5.h)
  • A new filebased blobcache. sqlite just didn't make it
  • Add pool_num()
  • Fix http_ctime()
  • theme: Add missing SkipBack and SkipNext icons
  • svg: Add support for
  • The file bundler does not really support file with spaces, so avoid that
  • upnp: Grab albumart for images and videos as well
  • theme: Move video title above image
  • docs: Mention from which version settings.createMultiOpt() is available



Showtime PS3 Media Player Repack v3.3.344 Update is Released

Stay tuned for more PS3 Hacks and PS3 CFW news, follow us on Twitter, Facebook and drop by the PS3 Hacks and PS3 Custom Firmware Forums for the latest PlayStation 3 scene and PlayStation 4 scene updates and fresh homebrew PS3 Downloads. Enjoy!


  • Sponsored Links




#560 - PS4 News - 19w ago
PS4 News's Avatar
The later versions of it are working fine here: http://www.ps4news.com/ps3-hacks-jailbreak/showtime-ps3-media-center-v4-6-4-latest-stable-build-for-playstation-3/

#559 - fany33 - 19w ago
fany33's Avatar
Hi can you pls update links again ? There is error 404 on every stream thx

#558 - topantita - 20w ago
topantita's Avatar
Quote Originally Posted by spideygower View Post
I have suddenly run into trouble! Been playing back ups and watching files on showtime now suddenly it they don't boot.

I have rogero 4.55 and that it what my system is set at. I have a fat ps3 JB 160gig. I recently did a few updates to showtime and multimsn , maybe I messed it up.

What happens if I try and start showtime or multiman is it goes into a black screen and I have to restart ps3.

Any help will be greatly appreciated. Thanks


you can delete multiman, and reinstal latest multiman 4.66 package...
maybe it solve the problem...

#557 - xmanme - 20w ago
xmanme's Avatar
great.

is it running youtube videos in 1080p ?

#556 - washington62788 - 22w ago
washington62788's Avatar
Thank you

#555 - haselhof - 23w ago
haselhof's Avatar
Awesome! I've been looking for something like this. Keep up good work.

#554 - antiviruz - 23w ago
antiviruz's Avatar
wooooooow this is very cool, thanks

#553 - ahmadaou - 23w ago
ahmadaou's Avatar
Cool

#552 - sirgilmour - 24w ago
sirgilmour's Avatar
cool

#551 - antcarlovisk - 26w ago
antcarlovisk's Avatar
thanks a lot !!