PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!

Home PS4 News - Latest PlayStation 4 and PS3 News

238w ago - Update #2: Jevinskie has now has coded the PL3 branch to now work on PSGroove devices, evilsperm has compiled PSGroove Jevin Firmware available HERE and RichDevX has released a 3.40 (Static) Debug Payload and a 3.40 + 3.41 (Static) Debug Payload so PS3 Debug users can utilize PSGroove to dump kernels, etc.

Update from KaKaRoTo, to quote: "Philhug and I have worked together recently to make PL3 compatible with 3.15, and it is now done, working and ready for you to use.

I have just pushed the latest changes to github, so just update both PSFreedom and PL3, and define FIRMWARE_3_15 in PSFreedom's config.h and recompile. You will then be able to enjoy your unrestricted PS3 on 3.15 firmwares. Enjoy!"

He also shared an IDA Script to Automate LV2 Dump today as detailed HERE.

Download: PSFreedom with PS3 Firmware 3.01/3.15 Support / PSFreedom PL3 3.01/3.15 Update / PSFreedom with PS3 Firmware 3.01/3.10/3.15 Support / PSFreedom PL3 3.01/3.10/3.15 Update

A few days ago we reported that more PSFreedom ports were on the way, and today KaKaRoTo has announced that PSFreedom now officially supports PS3 Firmware version 3.01.

Download: PSFreedom with PS3 Firmware 3.01 Support / PSFreedom PL3 3.01 Update

To quote: "I've got some great news for those of you who have not updated your PS3 firmware! I have just succeeded in adding Firmware 3.01 support into PSFreedom. I've pushed the latest code to github and you can now download the source and compile PSFreedom for 3.01.

For now, you will need to edit config.h and change the FIRMWARE_3_41 into FIRMWARE_3_01, then recompile. However, I will soon add support for dynamically choosing the target firmware version by simply doing a : echo 3.01 > /proc/psfreedom/fw_version

I will soon add support for firmware 3.10 and 3.15, so be patient, and you will be rewarded. I would like to thank Klutsh as well as Philippe Hub who helped me achieve this port to 3.01. The new payload changes are available in the PL3 github and any project/port that is also using PL3 should automatically gain support for the 3.01 firmware.

You will also be able to enjoy some new 'tools' in PL3 that will allow you to dump the LV2 kernel as well as the decrypted ELF files of the XMB and other configuration files it uses. The ethernet dumping is also now compatible with PS3 Slim models.

I would like to thank, again, those who have donated. For the others, you can still donate, if you appreciate the work I've done. Enjoy!"

Good news! I wonder what would happen if you dump the dev_flash for 3.01 and run it on 3.41



PSFreedom Now Officially Supports PS3 Firmware 3.01

Stay tuned for more PS3 Hacks and PS3 CFW news, follow us on Twitter, Facebook and drop by the PS3 Hacks and PS3 Custom Firmware Forums for the latest PlayStation 3 scene and PlayStation 4 scene updates and fresh homebrew PS3 Downloads. Enjoy!


  • Sponsored Links




#98 - kornwood - 238w ago
kornwood's Avatar
i should have asked earlier, is a bd drive required?

#97 - Flipk - 238w ago
Flipk's Avatar
@evil_sperm double confirmed, kungfu panda runs (didn't have a disc in hence not working) sweet now to buy a bigger internal drive

#96 - evilsperm - 238w ago
evilsperm's Avatar
I tried a dump of 3.15 on my 3.41 with firmware loader but it muffs up the xmb pretty bad lol, anyway open another thread for that or this thread will get flooded.

#95 - BwE - 238w ago
BwE's Avatar
still no news on copying dev flash?

#94 - Koneesha - 238w ago
Koneesha's Avatar
Oh. Really? I must have missed that post then? So what's the issues, not booting, or just like the unknown usb, or something more drastic?

#93 - evilsperm - 238w ago
evilsperm's Avatar
someone already ported it to the ti but its having the same issues.

#92 - Koneesha - 238w ago
Koneesha's Avatar
I was wondering if its possible for this to work on the TI 84s? Or is the coding for that completely different or something. If so could someone point me in the right direction to code it all, or something?

#91 - kornwood - 238w ago
kornwood's Avatar
i get the unknown usb error i can install packages but can run any of them.

#90 - evilsperm - 238w ago
evilsperm's Avatar
thejindesan: That's good news! the issue with the unknown usb device is still a showing its ugly face... but as long as its launching games I dont see an issue with that error

kronwood that one I just posted will work on blackcat also, as well as maximus and minimus.

I would like to see if a few more people can test it out and launch a few games.

~evil

#89 - kornwood - 238w ago
kornwood's Avatar
i could test the a blackcat file.