PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!

Home PS4 News - Latest PlayStation 4 and PS3 News

221w ago - Today the MC68000/Z80 arcade emulator for PlayStation 3 has been updated to FBANext PS3 Custom Build v2 (Wonderpatch) FIXED r417 and now supports Firmware 1.92 and 3.41 for PS3 JailBreak users and GeoHot Custom Firmware 3.55 as well, followed by r22 with a PARAM.SFO fix and r422 Custom v1 which adds a 1.92 PKG fix and triple buffering.

Download: FBANext PS3 Custom build v2 FIXED r417 / FBANext PS3 r422 / FBANext Custom build v2 r422 Custom v1 / Source Code

Below are the changes, to quote from the list: FBANext PS3 - Custom build v2 - FIXED - r417

CHANGES (as of r417):

  • Resolution switching in Settings menu - select resolution with left and right on D-pad and press X to switch to the resolution.
  • Much better framerate due to audio tweaking - now stays within the 59.900 ballpark and beyond instead of hovering somewhere between 59.200 and 59.900.



FBANext PS3 Emulator Updated, Custom Build and CFW Support!

Stay tuned for more PS3 Hacks and PS3 CFW news, follow us on Twitter, Facebook and drop by the PS3 Hacks and PS3 Custom Firmware Forums for the latest PlayStation 3 scene and PlayStation 4 scene updates and fresh homebrew PS3 Downloads. Enjoy!


  • Sponsored Links




#91 - rickyrolls - 219w ago
rickyrolls's Avatar
I wish I did just have a problem finding roms, I been up all night trying to install this. I am on 3.55 waninkokos V2 CFW. I have downloaded like 6 or 7 different versions, 2 have installed and then error when I try to load, the others won't install at all. I only see geohots CFW everywhere I look, did I mess up going from 3.41 OFW straight to 3.55 CFW?

#90 - OriginalXOR - 220w ago
OriginalXOR's Avatar
Sorry to sound so dumb, but how do I apply these patches please?

#89 - itwalksamongus - 221w ago
itwalksamongus's Avatar
Please add a default path to USB:/FBAROMS or something, it's just one extra line in the .xml and it'll save a lot of people screwing around with ftp's and pc's.

#88 - thematty13 - 221w ago
thematty13's Avatar
please help, cp roms ok but i can't get neo geo or anything else to work. i'm on kemos 3.55 im useing 3.41 emulator i'll run neo geo roms and it says sfix error. what's wrong, and do i need to have a bios in the rom folder? please help, i'm new to arcade emulators. thanks

oh and i do run the 3.41 one right? what about these patch ones..

#87 - squarepusher2 - 221w ago
squarepusher2's Avatar
Nope, nothing got changed on that front (depends what previous version you were working with, though).

The only thing I can think of that might have happened is that the XML config file got overwritten when updating. You might need to set up the ROM paths again with a text editor.

BTW - this is a huge pain in the collective you-know-what - I'm going to try hacking a 'Set ROM path feature' into FBA and have FBA save it.

#86 - busta phillips - 221w ago
busta phillips's Avatar
Same here, my CPS3 roms were all working on an earlier version. Now 3rd strike and JoJo are missing files I guess... I guess the roms got updated. Can anyone confirm?

#85 - FernanditoJr - 221w ago
FernanditoJr's Avatar
can't seem to find a Street Fighter 3rd Strike rom that works for me. Anybody care to share?

ps: is it normal for the emulator to work without using the dongle (on 3.41)?

#84 - toholassud - 221w ago
toholassud's Avatar
version 1.92 is good. Thanks for the update squarepusher2

(I return to the underworld...)

#83 - squarepusher2 - 221w ago
squarepusher2's Avatar
FBANext PS3 - Custom build 2v2 - r422 (FW 1.92+/FW 3.15/FW 3.41/Geohot CFW 3.55)


CHANGED since 442:
- 1.92 PKG should work now.
- Turned on triple buffering - led to a helpful speed increase. Especially noticeable in Street Fighter 3rd Strike

#82 - squarepusher2 - 221w ago
squarepusher2's Avatar
I just noticed that the PARAM.SFO was made in such a way that the minimum required firmware was 3.40.

Therefore, here is a short interim release - r422 - all of my patches have become part of the official version (post-417).

FBANext - PS3 - r422 (FW 1.92+/FW 3.15/FW 3.41/CFW 3.55)

I want to implement some more stuff - but that will have to wait until later.

 











Advertising - Affiliates - Contact Us - PS4 Downloads - PS4 Forums - Privacy Statement - Site Rules - Top - © 2015 PlayStation 4 News