PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!

Home PS4 News - Latest PlayStation 4 and PS3 News

210w ago - Today Andoma has updated the Showtime Media Player PS3 homebrew port to version v2.99-284 with changes detailed below.

Download: Showtime Media Player PS3 SELF (v2.99-284) / Showtime Media Player PS3 PKG (v2.99-284) / GIT

Showtime Media Player PS3 v2.99.284 Changelog:

Mostly bugfixes in this release, here are the highlights:

  • ps3: Fix video bitrate calculation when using SPU decoder
  • Fix bitmapped subtitle formats (VOBSUB) on bigendian (such as PS3) systems. Ticket #433
  • Fix scanning of SRT subtitles Ticket #408.
  • webdavclient: Strip 'http://host' in webdav responses before parsing. Ticket #426
  • linux: Prefer openssl over libssl
  • ps3: Use system fonts (Latin, Japanese, Korean, Chinese) so lots of more characters should work now
  • subtitles: Autodetect encoding of SRT files
  • ps3: Fix seeking bugs when playing with cell acceleration
  • ps3: Force cell decoder into level 4.2 even if content is 5.x
  • Add support for all ISO 8859 character encodings and make it configurable in Language -> Settings which default character encoding to use for SRT files.



Showtime Media Player for PS3 Updated to v2.99-284

Stay tuned for more PS3 Hacks and PS3 CFW news, follow us on Twitter, Facebook and drop by the PS3 Hacks and PS3 Custom Firmware Forums for the latest PlayStation 3 scene and PlayStation 4 scene updates and fresh homebrew PS3 Downloads. Enjoy!


  • Sponsored Links




#560 - PS4 News - 18w ago
PS4 News's Avatar
The later versions of it are working fine here: http://www.ps4news.com/ps3-hacks-jailbreak/showtime-ps3-media-center-v4-6-4-latest-stable-build-for-playstation-3/

#559 - fany33 - 19w ago
fany33's Avatar
Hi can you pls update links again ? There is error 404 on every stream thx

#558 - topantita - 19w ago
topantita's Avatar
Quote Originally Posted by spideygower View Post
I have suddenly run into trouble! Been playing back ups and watching files on showtime now suddenly it they don't boot.

I have rogero 4.55 and that it what my system is set at. I have a fat ps3 JB 160gig. I recently did a few updates to showtime and multimsn , maybe I messed it up.

What happens if I try and start showtime or multiman is it goes into a black screen and I have to restart ps3.

Any help will be greatly appreciated. Thanks


you can delete multiman, and reinstal latest multiman 4.66 package...
maybe it solve the problem...

#557 - xmanme - 19w ago
xmanme's Avatar
great.

is it running youtube videos in 1080p ?

#556 - washington62788 - 21w ago
washington62788's Avatar
Thank you

#555 - haselhof - 23w ago
haselhof's Avatar
Awesome! I've been looking for something like this. Keep up good work.

#554 - antiviruz - 23w ago
antiviruz's Avatar
wooooooow this is very cool, thanks

#553 - ahmadaou - 23w ago
ahmadaou's Avatar
Cool

#552 - sirgilmour - 24w ago
sirgilmour's Avatar
cool

#551 - antcarlovisk - 26w ago
antcarlovisk's Avatar
thanks a lot !!