PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!

Home PS4 News - Latest PlayStation 4 and PS3 News

228w ago - Update: KaKaRoToKS has now confirmed that the PS3 3.55 downgrade is no longer possible, tweeting the following: "sad news.. downgrade worked, but not reliable, only works with one of Xtse's ps3s, but can't reproduce it.. I'm going to look for another way. nope, it only works on one machine, even if same model, it doesn't work on it. No idea what's different about it..."

Today KaKaRoToKS has confirmed via Twitter news of PS3 downgrade success from version 3.55 to 3.41 PlayStation 3 Firmware.

This confirmation comes just days since his PS3 Custom Firmware surfaced and under a month after the PSGrade free PS3 Downgrading hex codes arrived for version 3.5 and below consoles, followed by Sony revoking lv2diag.self file_1 and patching PS3 downgrading in the PS3 Firmware 3.55 update.

Here is his Tweet, to quote: "First downgrade from 3.55 to 3.41 successful, Thanks to Xtse! Method not yet ready for the masses because of risk of bricking the ps3."

Currently this is all the details available, but we will update this post as more surface as always!


PS3 Downgrade Success from 3.55 to 3.41 Firmware Confirmed

Follow us on Twitter, Facebook and drop by the PS3 Hacks and PS3 CFW forums for the latest PlayStation 3 scene and PS4 Hacks & JailBreak updates with PlayStation 4 homebrew PS4 Downloads.




#8 - hackerxide - 228w ago
hackerxide's Avatar
Correct me if i'm wrong, but couldn't we just install the 3.41 custom firmware, or do you need specially signed homebrew, and also great find, sony should just give in to us, and start working on a new project.

#7 - thrasher956 - 228w ago
thrasher956's Avatar
awesomeness! The ps3 scene is really on the go.

#6 - anulu82 - 228w ago
anulu82's Avatar
Quote Originally Posted by Link14 View Post
Great news !

But why working on a downgrade instead of working on a modified 3.55 firmware which also backup loaders ?

I prefer wait for a cfw and I think I'm a not alone in this case.


if i can downgrade to 3.41 and use JB, and when i want to play with GT5 (original) then i upgrade, that would be also awesome for me. and we all know that the utils on 3.41 are working.

#5 - PS4 News - 228w ago
PS4 News's Avatar
Quote Originally Posted by Link14 View Post
But why working on a downgrade instead of working on a modified 3.55 firmware which also backup loaders ?

That is just his decision not to support backup loaders, sooner or later someone else will end up releasing one for PS3 Custom Firmware so I wouldn't worry too much.

#4 - vulcan4d - 228w ago
vulcan4d's Avatar
wow sweet news. Hopefully this will work with the stubborn new preloaded 3.50 firmware that won't downgrade either.

#3 - Link14 - 228w ago
Link14's Avatar
Great news !

But why working on a downgrade instead of working on a modified 3.55 firmware which also backup loaders ?

I prefer wait for a cfw and I think I'm a not alone in this case.

#2 - anulu82 - 228w ago
anulu82's Avatar
great morning news!

#1 - geopis - 228w ago
geopis's Avatar
wonderful news. well done kakaroto... keep walking!