PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!

Home PS4 News - Latest PlayStation 4 and PS3 News

207w ago - Here is a brief update from PS3 hacker Waninkoko, sharing his thoughts on how to develop a full-fledged PS3 CFW 3.60 / 3.61 followed by some details from groveritos below.

This news comes following a PlayStation 3 Custom Firmware hybrid update to PS3 CFW VENIX S-PLUS Spoofing 3.65. To quote, roughly translated:

1. Private keys can not be calculated for any firmware> = 3.56, and are NOT in any site, which for some are private (only the Sony has, and if we make a mistake it was thanks to them which they applied the algorithm So encryption of data and a few mathematical operations could calculate the private keys).

2. IF you can create a CFW 3.61, the only obstacle is to get the public keys, which can be drawn SI, with varying degrees of difficulty but you can. Each loader is encrypted with a private key and decrypted with the corresponding public key. But the lowest level loader in a FW is encrypted and decrypted with the root key, which is invariably because the root public key used to decrypt the loader is located in the metldr (obviously, the metldr will have to have the public key to decrypt the loader) and metldr NOT be updated in any way, so that the root key can not be changed from one version to another firmware because it is sad if any.

So if you want to create a CFW of 3.61, changing the LV2 to add new features, we have to go hacking the chain of loaders to get on. Example:

METLDR -> LV0LDR -> LV0 -> LV1LDR -> LV1 -> LV2LDR -> LV2

More or less this is the chain of loaders (do not know if there is some small variation in FW 3.61).

METLDR, as I said, NO you can update.

METLDR LV0LDR decode the root key (LV0LDR loader is the lowest level, if we do not have to METLDR) and executes it.

LV0LDR LV0 decode the LV0-key (this key if you can change between versions of firmware as LV0LDR SI is upgradeable and can therefore LV0 encrypt a private key and update LV0LDR to decode it with the new corresponding public key) and runs.

Decrypts LV0 LV1LDR ....

LV2 LV2LDR decrypts the lv2-key and executes it.

Therefore, if you want a CFW, we need to decipher LV0LDR (with the root key, which geohot public and will never change), change LV0LDR change LV0 decryption key (the change of a key that is capable of decoding a LV0 encrypted with a private key that we DO know ... that private key? anyone, as if we generate a key), encrypt LV0LDR with the root key, and we can modify LV0 to our liking and is now LV0 deciphered with a different public key, which we know the private key. And so we change the whole chain to LV2, modify and recifrarlo with the new key we've chosen.

Well, that's the way broadly told (when I say encrypt / decrypt, I do not mean the contents of the loaders, because it works with AES encryption and symmetric and there is no question of public / private key, but I mean really at the head of such loaders, for signature, which uses RSA keys is where public / private partnerships, with the sole purpose of checking that these loaders have NOT been changed).

In the case of FW 3.61 the track is a bit more complex as there are RSA public key and AES keys that are easy to obtain, but hey, there are methods to obtain, there are people who have them, and therefore it is not impossible .

Now, we must take into account that a CFW can be installed only if the console is in a FW 3.55 or lower, because higher versions will make use of a new updater, which verifies the upgrade package (internal data the PUP, so I understand) by checking with new firms (which had not previously existed and are now mandatory) which we have neither the public nor the private key (the public can take, but privately we can forget and here no no chain so we can prevent this ... the updater is a separate application of FW and no longer has to do with the above explained).

Said this last, some will think that if the upgrade to a CFW 3.56/3.60/3.61 and thou mayest not reinstall any other CFW (that is, you stay forever in that CFW or FW actualizais an official). The answer is yes, but hey, is not inevitable and that, in creating this CFW, we can modify the VSH (or one) to use the old updater (which does not check new firms and therefore we have no obstacle to install new CFW), or modify the APPLDR to allow us to load the new updater but modified to not check signatures (the new updater can be changed, of course, but also need to modify our FW APPLDR currently installed to the recifrar updater with a private key known and APPLDR then be able to decrypt and run).

And that's all.

From groveritos: teknoconsolas.es/foro/viewtopic.php?f=214&t=98319&hilit=

[Register or Login to view code]




Waninkoko Explains How to Develop a PS3 CFW 3.60 / 3.61

Follow us on Twitter, Facebook and drop by the PS3 Hacks and PS3 CFW forums for the latest PlayStation 3 scene and PS4 Hacks & JailBreak updates with PlayStation 4 homebrew PS4 Downloads.




#110 - Ezio - 195w ago
Ezio's Avatar
The only thing you can do to jailbreak your PS3 is going back to the 3.55 fw via downgrade with progskeet, teensy or infectus as appropriate.

#109 - stanejindu - 195w ago
stanejindu's Avatar
please , can I jailbreak my ps3s 3.56 and 3.60?

I have 2 ps3 and need to jailbreak them they are 3.56 and 3.60 what do I do?

#108 - HeyManHRU - 195w ago
HeyManHRU's Avatar
Exactly, If 3.70 CFW does happen to come out, 3.80 OFW will come out a few months later and we're all back to the drawing board.
We should be thankful that we have a CFW to start of with and we don't have to go off buying dongles.

If you want online play and all the latest games Update to OFW or buy a second PS3. It's pretty simple.

#107 - jthorn89 - 195w ago
jthorn89's Avatar
hi, i know this is my first post and yes i'm a noob i was reading through the thread and had to comment i understand there is no 3.56+ hopefully we will get 1 soon but if not oh well. i'm on cfw kmeaw 3.55 but just alil advice to my fellow noobs go out and get 3 ps3s they are cheap go on craigslist ppl will trade anything now days like a airsoft gun or ipod touch well anyways have 1 on cfw 3.55 (may be alil harder to get) and 1 on 3.70 4 psn access and one to sit and collect dust until a new cfw is released.

the devs are prob gettin sick of hearing all the whining seriously friends when its released to the public you'll know your not going to get it any faster if you demand it the devs don't even have to work around the clock so we can have cfw they choose to help us out if you want a new cfw that bad then learn how to do it and tell us how easy it is. i mean really don't mean to offend anyone but its usually the 13 year old kids begging for cl for mw2.

#106 - jamesnesc709 - 195w ago
jamesnesc709's Avatar
there is no just thing yet a jailbroken 3.66 yet only for 3.55 cfw and only one for 3.70 is a spoof that it nothing more just be patient.

#105 - Wiigl3 - 195w ago
Wiigl3's Avatar
hello guyz,

I recently had the 3.66 jailbroken until I had to upgrade to 3.70. Now i feel powerless in order to host my challenge lobbies for mw2.

Where can I get the jailbreak for 3.70?

thnx in advance

#104 - snikes - 196w ago
snikes's Avatar
I second that.

#103 - Natepig - 196w ago
Natepig's Avatar
Unless its been verified genuine by known trusted people, anything ps3 related should be considered fake and not used.

#102 - k3n5h1n30 - 196w ago
k3n5h1n30's Avatar
aw man

#101 - Ezio - 196w ago
Ezio's Avatar
That video is more fake than real. The author of video isn't a reliable man, so it is fake 100%. LOL