PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!

Home PS4 News - Latest PlayStation 4 and PS3 News

October 25, 2011 // 3:07 pm - Today PS3 News member ChronosAragami has suggested a quick and effective way to launch Rune Factory Ocean on PS3 3.55 Custom Firmware.

Those interested can simply do the following:

1. Grab JAP version dump of this game, we will use it as a base.
2. Replace "RFF2.bin" and "RFF2.dat" with US eqivalents
3. Replace japanese "Sounds" and Movies with US ones.
4. Enjoy game!

To quote: "Sorry my bad English, I am Brazilian hehe, I'll cut to the chase, I discovered that if you swap the files RFF2.bin RFF2.dat, from the American version to the Japanese version, the game going to be with the texts in English and Japanese audio.

That's it, just wanted to share with others who enjoy this game. Thank you for your attention.

Ops, the JAP audio its not working, if you want to hear the villagers voice, put all the Sounds from USA version in the JAP version."

PS: I do not have this game, whole instructions and all credits goes to ChronosAragami. Ask him for questions


Rune Factory Oceans PS3 Custom Firmware Fix Arrives

Follow us on Twitter, Facebook and drop by the PS3 Hacks and PS3 CFW forums for the latest PlayStation 3 scene and PS4 Hacks & JailBreak updates with PlayStation 4 homebrew PS4 Downloads.



#41 - Bartholomy - November 20, 2011 // 2:18 pm
Bartholomy's Avatar
Sorry if i ask, but why all of this? Just jap version works with 3.55?

In case, this thread would be awesome if the jap 3.55 version was linked for download, than using those new files, will be a perfect fix
What do you think?

#40 - Tidusnake666 - November 20, 2011 // 1:59 pm
Tidusnake666's Avatar
Thanks for clearing up, and +REP!

#39 - gusql - November 20, 2011 // 12:40 pm
gusql's Avatar
Compilation of information I got reading this forum and other stuff:

1. Grab JAP version dump of this game, we will use it as a base.
2. Replace "RFF2.bin" and "RFF2.dat" with US equivalents - that's where the english texts are I guess, some texts jump out of the conversations some times because a whole english phrase is bigger than a japanese one, but it's totally readable!
3*. Replace japanese "Sounds" and Movies with US ones *if you want a game with english voices* (haven't tested this part actually)
3. Replace japanese "Sounds" with the megaupload ChronosAragami left on page 1 - he changed something in those files to make the japanese sound work, although there are some sentences in which the characters don't speak(I'm not even if they are actually meant to speak but it doesn't really bother me at all).
4. Replace STRM_BGM and STRM_BGM2 with US equivalents(sound folder) - if you just leave the japanese files, them you won't have a lot of sounds in your game since both files together are like 650mb while all the other sound files 350mb. Those two files don't have the sounds of characters speaking I think, just stuff like singing at some parts of the game and saying good morning when waking up(something like that), but mostly random sounds.

I left the japanese movies, since I didn't see much speaking on movies in the beginning of the game, haven't tested the game using the US movie files. I can't see sometimes the instructions on what button to use, but it's easy to figure it out.

Since we are using a japanese release, then X works as O and vice versa.
When putting the names, just press start for the default name or press X until no letters appear and then press square and just write the name, although only 1 letter at a time appears it's gonna work out(I think 6 is the max, but not sure).

Sometimes the calendar gets buggy, normally loading the game makes it right again or maybe just exiting the house, haven't tried to test everything. The game only works on external and select+x on multiman.

I think that's it.
PS: all credits goes to ChronosAragami.

#38 - MrBEST - November 19, 2011 // 4:23 am
MrBEST's Avatar
I don't have any sound there is the sound of the forest and such but no background sound no charecter sounds when i press select and X i get the error message that the game cannot be transferred/copied to the directory any idea why??

This happens only when i copy anything besides the Rff files for example the sounds or movies when i try to start the game i get black screen. I have tried everything exept burning the game onto the dvd which i don't really know how. Any ideas why??

#37 - windstorm - November 7, 2011 // 5:27 pm
windstorm's Avatar
Can anybody share with me by PM the links of the release you used ENG and JAP version, thanks.

#36 - Remnence - October 29, 2011 // 11:33 am
Remnence's Avatar
That didn't work for me either Tidus. For those that have voices working, did you do anything special? What release groups did you download? What version of Multiman/Launcher are you using?

#35 - Someone2 - October 29, 2011 // 4:23 am
Someone2's Avatar
Got it to work in the 1st try real easy, thx ChronosAragami

#34 - Tidusnake666 - October 29, 2011 // 2:04 am
Tidusnake666's Avatar
I really haven't laid a finger on this fix, nor tested this. All credits/replies goes to ChronosAragami. Someone replied they got it work, someone do not. Maybe I'll look into it when I'll have some free time.

It maybe silly, but have you tried launching any other original BD game to clear cache and delete game data than reload Rune Ocean? Maybe this is the cause of it - all those fixes you're making doesn't apply to game because of it using old cache. Just a hunch, it was a common problem with Disagea 4 and Atelier Totori fixes.

#33 - 1Panic - October 28, 2011 // 10:32 pm
1Panic's Avatar
lol This doesn't sound good. Sounds like its pretty hard to manually do it ourselves... I'm sorry but I am not into doing all the work myself which is what you guys are doing. There should be a team that has "one" file that does it for us.

#32 - Remnence - October 28, 2011 // 10:07 pm
Remnence's Avatar
The file structure is /Synth/S1/*.aax for both STRM files. Each of the other cpk files have a different file structure. I have verified that they are packed correctly, but no voices play. Music works fine.