PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!

Home PS4 News - Latest PlayStation 4 and PS3 News

July 20, 2009 // 8:56 am - I slapped the 'rumor' status on this one for now until others can confirm it... today TheSixthAxis.com (linked above) via CVG are claiming that Sony finally pushed the button marked "obligatory" on PS3 Firmware Update 2.80.

This comes after Sony's Director of Network Operations stated that with 2.8 it was an option to update as there wasn't any consumer-specific functionality.

According to both the US and EU Updaters, it still is showing only 2.76 is required to go online with the PS3, as follows:

Dest=84;CompatibleSystemSoftwareVersion=2.7600-;
Dest=85;CompatibleSystemSoftwareVersion=2.7600-;

If anyone can confirm otherwise, feel free to do so in the comments below!

Rumor: PS3 Firmware 2.80 Update is No Longer Optional?

Follow us on Twitter, Facebook and drop by the PS3 Hacks and PS3 CFW forums for the latest PlayStation 3 scene and PS4 Hacks & JailBreak updates with PlayStation 4 homebrew PS4 Downloads.



#14 - GrandpaHomer - July 21, 2009 // 2:11 am
GrandpaHomer's Avatar
Quote Originally Posted by zoned View Post
I was forced to update to 2.8 when i updated vidzone at the weekend.


The same here - I was pushed to update my second PS3 (80 GB EU model) to 2.80 yesterday evening after VidZone update - so it IS (semi)mandatory now ...

My first (60 GB EU Model) was updated already for a while as I'm using the Text Chat a lot and it was improved considerably with 2.80 ...

#13 - Norman Bates - July 21, 2009 // 12:29 am
Norman Bates's Avatar
Quote Originally Posted by zoned View Post
I was forced to update to 2.8 when i updated vidzone at the weekend.


I've read rumors about 2.80 containing some updates for vidzone, maybe thats why you had to update your firmware. Still waiting for vidzone to come out in Sweden.

#12 - ionbladez - July 20, 2009 // 7:44 pm
ionbladez's Avatar
40GB PS3, USA, FW 2.76 - Logs in, playing socom now.

#11 - RadioactiveSoup - July 20, 2009 // 4:59 pm
RadioactiveSoup's Avatar
Just checked, still running on 2.76 with no forced update.

#10 - maxpwer222 - July 20, 2009 // 4:40 pm
maxpwer222's Avatar
Quote Originally Posted by sippyboi View Post
why would they force you to update??

Various reasons. Mostly because they can or the updates build upon each other.

I have not been asked to upgrade yet. US.

#9 - sippyboi - July 20, 2009 // 4:22 pm
sippyboi's Avatar
why would they force you to update??

#8 - mckarlsson - July 20, 2009 // 1:08 pm
mckarlsson's Avatar
Quote Originally Posted by zoned View Post
I was forced to update to 2.8 when i updated vidzone at the weekend.


me2
/ europe vers. / Germany / 40GB Edt.

#7 - canabal - July 20, 2009 // 12:54 pm
canabal's Avatar
I updated a while ago, made a huge difference for playing videos. Before I could not fast forward/rewind/resume HD videos on the HDD, now it works perfectly.

#6 - zoned - July 20, 2009 // 12:48 pm
zoned's Avatar
I was forced to update to 2.8 when i updated vidzone at the weekend.

#5 - Dreamcatcher - July 20, 2009 // 11:40 am
Dreamcatcher's Avatar
80 gb PS3
It has been optional in canada for some time now!