PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!




 
 
  1. #11
    untold_legends_usa-psp-dev

  2. #12
    Join Date
    Apr 2005
    Posts
    29,681

    Thumbs Up

    Thanks! I am working on updating the main news page over the next 30 minutes or so.

  3. #13
    is the loader gonna be for v1.00 Psp or v1.5 PSP????

    (i hope v1.5)
    Last edited by CrypticSoul; 06-08-2005 at 11:04 PM

  4. #14
    Join Date
    Apr 2005
    Posts
    29,681

    Arrow

    It will work on all versions (1.00, 1.50, 1.51, 1.52, etc) as it'll be a direct firmware change as far as we're told... so ya, you'll need to update to the "special" firmware that will allow you to play the UMD dumps from your Memory Stick.

  5. #15
    Quote Originally Posted by PS3News.COM
    It will work on all versions (1.00, 1.50, 1.51, 1.52, etc) as it'll be a direct firmware change as far as we're told... so ya, you'll need to update to the "special" firmware that will allow you to play the UMD dumps from your Memory Stick.
    wow...cant wait
    thx for the quick reply

  6. #16
    Join Date
    May 2005
    Posts
    201
    Quote Originally Posted by PS3News.COM
    It will work on all versions (1.00, 1.50, 1.51, 1.52, etc) as it'll be a direct firmware change as far as we're told... so ya, you'll need to update to the "special" firmware that will allow you to play the UMD dumps from your Memory Stick.
    So that means that when the loader is released, I can go out and buy a US PSP, and the loader will work?

    I was wondering if we should expect any loss in speed or less battery consumption by playing off Mem Stick?

  7. #17
    Join Date
    Apr 2005
    Posts
    29,681
    Actually the battery consumption should be less from MS, as the UMD drive motor won't need to be used for turning the disc, but until the PSP Loader is available anything more is just speculation really.

  8. #18
    How can we update the firmware?Have anyone found a way to update the firmware?I worried about the version 1.5 running on PSP,cuz there aren't any third-party software avalible on version 1.5.

  9. #19
    Might be a stupid question, but I'll take that chance as I always do; will this alleged loader also allow me to run all of the emulators available on my 1.5?

  10. #20
    i wonder if all that will require a modchip, i doubt it will be free and simple

 
 


+ Reply to Thread
Page 2 of 5 FirstFirst 123 ... LastLast