PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!


 
 
  1. #11
    Join Date
    Aug 2005
    Posts
    6
    In France it has been reported stores having 1.52 euro psps.

  2. #12
    Join Date
    Aug 2005
    Posts
    3
    I've read the last few days saying that 2.0 won't get defeated. Myself can't see the reason why a new software updated only poses a temporary halt on the homebrew scene. Anyone who could back up the statement why people running 2.0 firmware should _never_(?) be able to use hombrew / wait an (extreme) long time for a fix?

  3. #13
    Join Date
    Apr 2005
    Posts
    29,953

    Cool

    Quote Originally Posted by Nolife
    I've read the last few days saying that 2.0 won't get defeated. Myself can't see the reason why a new software updated only poses a temporary halt on the homebrew scene. Anyone who could back up the statement why people running 2.0 firmware should _never_(?) be able to use hombrew / wait an (extreme) long time for a fix?
    I wouldn't worry... PSP Mods have already been completed for some time now, they override the OEM BiOS and you'll end up with a lot of sweet features you won't see for some time in 'homebrew' stuff probably. I'm sure in the next few months following the official Euro release they will be available for sale just as PSX and PS2 Mods were... and ya, they'll work on all version PSP units. It's all strategy... the developers are simply sitting on them as they know it'll be a goldmine around the holidays and since they will be released after the Euro PSPs there is no way $ony could implement any additional protection in time... securing a lot wider marketplace than just US/JAP regions. At this point I can confirm at least (2) developers have contacted us to let us know of such upcoming PSP products.

  4. #14
    The UK version is installed with 1.52, the demo disk that comes with it has the v2.00 upgrade, that mean i'm screwed for homebrew?

  5. #15
    Join Date
    Aug 2005
    Posts
    3
    If the European PSP's is released with the 1.52 firmware, how do I avoid beeing prompted to upgrade to 2.0 from UMD's? Imho, 1.52 is better off than 2.0 since there might come some software mod for 1.52 but not for 2.0.

  6. #16

    PSP 1.52 problem

    hi guys,

    i have a question about the PSP in Europe with the Firmware 1.52. Is there any chance to play released games with this PSP? can is use the fastloader to play the games in the compatibility list here of my PSP in version 1.52?

    i am sorry my english is not so good plz help me...

  7. #17
    Join Date
    Apr 2005
    Posts
    743
    not yet, maybe soon since there is rumors that there might be a fix to make it possible for firmware version 1.51 and 1.52.

  8. #18
    Join Date
    Apr 2005
    Posts
    29,953
    Quote Originally Posted by GismoCrack
    hi guys,

    i have a question about the PSP in Europe with the Firmware 1.52. Is there any chance to play released games with this PSP? can is use the fastloader to play the games in the compatibility list here of my PSP in version 1.52?

    i am sorry my english is not so good plz help me...
    Seriously bud, do some READING before posting and looking like an IDIOT here! It clearly states on our main page it isn't possible yet, if you can't comprehend that then you don't belong here. This is your only warning!

  9. #19
    Join Date
    Jul 2005
    Posts
    1
    @Nolife

    like it says in the news dont put the demo disc in the first time you power up your psp. so try a game first for sure. then it will not prompt you at all. its a menu point you have to select to update.

  10. #20
    Join Date
    May 2005
    Posts
    7
    Quote Originally Posted by odinsfire
    Is there a way of playing the demo disk without it updating the firmware to version 2.0?
    You can watch the demo's on the UMD without the psp automatically updating.

 
+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast

 
 
 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •