Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.


But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

  1. #1
    n4ru Guest

    Sports Champion PS3 Black Screen help?

    I can't get my copy of Sports Champion to boot.. Original Disc w/3.55 Spoof or Internal Drive Patched.

    After showing the Move intro, it black screens. I've tried launching the original disc with the 3.55 Spoof using both Hermes and PL3, and without the spoofs but patched to 3.41. I'm assuming it's the backup manager I'm using, but which one should I use?

    On second thought I think it may be the payload I'm using, considering that it won't even boot from the Original Disc.

  2. #2
    Sostanco Guest
    I have a backup copy of sport champions work on Hermes v4b + 3.5 sproof

    Using usb hdd + open manager 1.161 + p3hub1 device
    Ps3 slim 120 gb

    It work nice for me

  3. #3
    lavapants Guest
    I got Sports Champions for x-mas in the Move bundle. Tried loading it up via PSFreedom PL3 w/3.5 spoof and had the same black screen. I then tried Hermes V4, and I was getting an error code. I tried several different backup managers and had no luck. I was able to obtain a copy of the EUR Sports Champion and loaded it on my External HDD with PL3 w/3.5 spoof and it works flawlessly.

    I'm thinking maybe Sony changed something on newer shipped Sports Champions?

  4. #4
    CJPC Guest
    Its a possibility, best bet if someone were to grab it from the new disk, and give it a quick compare with that of the older disc to see if it was changed - a quick sha1sum of the files would do the trick.

  5. #5
    cackalack Guest
    I've got BCES 01012 (bought on release day of move controller) works absolutetly fine backed up or straight from disc, FW 3.41, PS3break V1.2 FW 1.7 3.50 spoof, open manager 2.01

  6. #6
    danishahmed Guest
    ya i was having the same problem and then I got a copy from blockbuster and swiched it with mine so its not like my copy doesn't work it just needs the update the old copy don't update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in