Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Red screen of death RSOD help please?

  1. #1
    baigomax Guest

    Exclamation Red screen of death RSOD help please?


    i have a PS3 with the famous RSOD, i try everything with the recovery mode, actually the ps3 is with the 3.50 firmware update via usb, any ideas? i'm from Argentina, here we donīt have SAT


  2. #2
    Extremeperson Guest
    My friend fixes xbox red rings by literally freezing the system, i think the only solution is a new ps3.

  3. #3
    cfwprophet Guest
    What does you mean with red screen?

    A little red window in the right down corner, displaying "Service Mode"?

  4. #4
    baigomax Guest
    here is the red screen of dead.. i hope someone helps me, is a real challenge!!

  5. #5
    Luckluka Guest
    To cfwprophet:

    Hehe, it was to good to believe that the console is in service mode

    To OP: Try swapping Hard-drives

  6. #6
    shummyr Guest
    I think the unit is dead, and there is no way of fixing the unit short of sending it into sony...


  7. #7
    Pool Guest
    I recently got a 80gb RSOD off Ebay, I've been messing around with it and have noticed something.

    I have the lid off the PS3 and I have been testing the drive to see if it works and I don't think it does. Sometimes it trys to read the disc when inserted and sometimes it doesn't even bother.

    If you go into the service menu and try to install the same firmware again, then mine was installing to around 33% then quickly completing.

    Then I tried removing the power to the Blu-ray drive just before I did another Firmware install (The machine needs to be switched on and at the accept firmware install screen). This time it gets to around 49% and fails with two different errors 8002F14E 8002F147

    Now when i try to install the firmware with everything plugged in it gets to 43% and quickly completes. Did this manager to flash some more of the nand? do you think. And is it possible that the reason my fails is because of the blu-ray drive? (controller maybe)

  8. #8
    TechGeek990 Guest
    Quote Originally Posted by baigomax View Post
    here is the red screen of dead.. i hope someone helps me, is a real challenge!!
    Sounds like the blu-ray drive is dead or the drive firmware is corrupted and is causing the system to RSOD. Have you tried recovery mode and reinstalling the 3.50 firmware while in recovery mode?

  9. #9
    baigomax Guest

    one step more!

    Hio people!

    POOL: my friend, thats good news for me, iīm going to try the same in my ps3, good observation!!, in case of firmware of BR are crap, what are we going to do next to probe? ANY IDEAS?, come on people! THE WORLD IS WATCHING US! NOONE FIX THAT RSOD! IF WE CHANGE THE BR unit?

  10. #10
    sykoNsc Guest
    i have a 60gb and the drive controller on mine is either dead or not original to motherboard, but i upgraded firmware from 2.something to 3.41 and had no problems whatsoever... so it's my belief that a dead controller, either bad or unoriginal, has no effect on firmware upgrades. now a bad laser or something to that effect may possibly be causing your issues.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts