Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.

But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

Page 1 of 2 12 Last
  1. #1
    umbyfish Guest

    Psjailbreak 2 dead help?

    hi people,

    last nite i've played AC Brotherhood a lot of time with ps3 and psjailbreak2, then i shut down the console normally with the PS button, but this morning the dongle was absolutely dead, both pc and ps3 don't recognize it and there are no life signal... a solution? thanks

  2. #2
    zeromx Guest
    Maybe (i'm just guessting here) its a cheap manufactured device or a clone, which are likely to overheat or short-circuit.

  3. #3
    Decker74 Guest
    Odd. I had the exact same problem last night. I have a PS3 Break, and it's not a clone, I did that 'truth inquiry' thing.

    I was playing ACB for quite a bit, and then it froze. On reboot, the key wouldn't work, and couldn't get it running. I reflashed, everything. Finally, I got it to work again by putting in an original disc and loading it, then shutting down and trying it again. Now it works about 50% of the time. Maybe try that and see if it helps.

  4. #4
    kylum Guest
    If your handy with a soldering iron. test/replace. make sure your ps3 usb didnt fail too...

  5. #5
    EiKii Guest
    sounds wierd, but guess its possible if its some bad clone, as above stated figure out if youre ps3 usb still works, if theres leds on the dongle maybe they died? but still works if you do as usual ?

    and btw what happens when you put it in ure pc? is it updateble? ie you can flash different payloads? also open the dongle and see if you can find any shorts or similar,

    a little more info from start would be nice

    hope you get it working again.


  6. #6
    umbyfish Guest
    well i've done some tests, the ps3 usb works fine with amazebreak v3.0, so it's not a usb problem, when putting the psjailbreak2 into the pc (i've tried 2 different machines) there are not life signals, i think the device is genuine because the offical site says that the clones are not upgradable and days ago i've upgraded mine with the latest psn spoof.

    for the leds, i don't think that they are simply gone and the device works normally, because the update program don't recognizes it... i've opened the device, i took some shots, here they are

    update: the pc after pluging in the dead device, seems to crash and needs to reboot manually.

  7. #7
    costocart Guest
    could this be because of AC:B ? anyone else playing this game has the same problem?

  8. #8
    ratatrampa Guest
    I have the SAME problem but for me was while I was not playing a backup, I just only reset the ps3 and the psjailbreak 2 dead, nothing recognize it but my PC don't seem to be worse when I plugged the dongle, did you do a test to verify if it had a short-circuit?

  9. #9
    severusx Guest
    Unfortunately, I think one of the capacitors on the PCB got too hot and shorted. Do you leave your dongle plugged in at all times or do you remove it after getting into the XMB? I had one of my boards with a AT90USB on it have the same problem, but since it is a dev board I was able to simply remove the damaged cap with a soldering iron and keep using it. I don't know what the warranty (if any) there is on those dongles, but it might be time to get a new one. Sorry.

  10. #10
    umbyfish Guest
    so it's officially dead, i will bury it in the garbage thanks a lot guys

    but after the console boots and goes into jb mode, can i unplug the jailbreakk device? (every kind of device? amazebreak?)

Page 1 of 2 12 Last

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Log in