PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!


 
 
  1. #1

    [Answered] PS3 won't accept discs after laser replacement help?

    I recently bought a new laser mechanism with deck for my PS3 slim. My older laser stopped reading discs, therefore I bought a new one.

    I installed the new laser with deck and now its not accepting/sucking discs. However, when I reassemble it back to my original laser lens, it worked and it accepted/loaded the discs. But the original doesn't read discs though which is the reason why I bought a new one.

    One thing did go wrong when I was assembling the new laser mechanism with deck. The brown ribbon had 2 ribbons. One long one and a short one at the top of the other ribbon. Well I accidentally split them apart when I was trying to connect it back.

    I just connected them both manually into the connecter even though both are not stuck together like it should be.

    Could be this be the reason why it isn't accepting discs ?

    I attached an image I found online, so you know what I'm talking about.

    Any help is appreciated, thanks.
    Attached Thumbnails<br><br> Attached Thumbnails

    sku_121694_1.jpg  
    Best Answer - Posted by racer0018:

    Try and take the lens out of the new one and put it in the old one. The thing is that if the laser doesn't move back and forth it will not accept the discs. Switch just the lasers and see what happens. Thanks.

  2. #2
    Join Date
    Sep 2010
    Posts
    818
    Well photo you have is motor from laser head movement , i do not see how this could be faulty it's very rare or all almost impossible that this motor would be faulty and it has nothing to do with sucking discs inside.

    My guess would be to disassemble drive and do it one again slowly , make photo of faulty part according to you and paste it here it might help

  3. #3
    What causes for not being be able to suck discs inside ?

    I made sure all the ribbon cables were plug in correctly and I was extra careful the last time I did it. I already assemble it a couple of times, and still got the same result. The original laser deck does suck discs which I'm confused what the problem could be. So I assume the product I bought is defective ?

    I put two pictures.

    1. The part that I'm talking about
    2. The whole laser with deck

    PS3 Model # : CECH-2101A
    Original Laser : KEM-450AAA (label in a sticker)
    New Laser : The one I bought is label as the following : KES-450A/KES-450AAA/KEM-450AAA laser lens + spin motor + deck for a PS3 CECH-2101A/120GB
    Attached Thumbnails<br><br> Attached Thumbnails

    IMG_0894.JPG   IMG_0896.JPG  

  4. #4
    Join Date
    Aug 2007
    Posts
    901
    Try and take the lens out of the new one and put it in the old one. The thing is that if the laser doesn't move back and forth it will not accept the discs. Switch just the lasers and see what happens. Thanks.

  5. #5
    I have the exact same problem. That brown ribbon cable seems to be loose and my ps3 slim doesn't accept any disc. How did you fix this problem valdo?

 
Closed Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •