1. #1
    Join Date
    Apr 2010
    Posts
    109

    PS3 Upgrade Opinions help?

    Hi all,

    This isn't a "how to" upgrade question, but more of an opinion question. I'm currently on Rebug 3.55.4 w/QA flag enabled, and thinking it is time to upgrade to a newer Rebug firmware (which should be easy for me).

    It's probably time I upgrade at this point, but I'm not sure what version would be best. I like Rebug and would like to stick with it. I have zero interest in trying to get online, so 4.46 isn't really a necessity just yet. I would like to play some semi recent games, and be able to use ReactPSN. It looks like 4.21 is pretty stable and has lots of support. Or would 4.30 be better? I want to make sure I can keep all my emulators running also. I heard there might be problems with MultiMan 4.46.01 (I'm at 4.20 still for MM) on Rebug 4.46 REX edition but don't know what.

    What do people think? Is one better than other? Is there anything not known to work on the latest 4.46 CFW at this point, or is it pretty safe to take the plunge?

  2. #2
    Join Date
    Jul 2013
    Posts
    125
    my mM works just fine, i'm on Rebug REX 4.46.1

    If you are not in rush , Rogero 4.30 v2.05 is just awesome. But i think 4.46 is easier and just good for any game in future.

    That's my opinion

  3. #3
    Join Date
    Apr 2010
    Posts
    109
    Thanks! I welcome more opinions, give your post count a workout!

  4. #4
    Join Date
    Sep 2010
    Posts
    959
    Just go as above rogero 4.46 works like a charm don't do 4.46.1 somehow ppl have trouble with this one and just uninstall multiman and install fresh 4.46 as well not the newest one

  5. #5
    Join Date
    Jun 2006
    Posts
    44
    I went to rebug 4.46 lite with the new MM. No problems. I'm converting all my old games. Ps1, 2 & psp. Most of them are working fine. The ones that don't are confirmed as not working but I tried them anyway. So to sum it up.... I'm happy on lite.

  6. #6
    Join Date
    Apr 2010
    Posts
    109
    I think I'm going to go with rebug 4.30. It seems like 4.46 is a little too new and I don't really need it. One of the games I want to play is duck tales and although there is a 4.21+ patch it sounds like this game actually needs 4.30 to function properly. I bought that game on steam but found out after that my old gamepad didn't work (doesn't support direct input, only some new gamepad interface).

    I'm not going to drop $30 on a new gamepad I only need for this game so I feel perfectly justified in playing it on my ps3 so I can enjoy my purchase. I'm picking a random response to mark as answered, but I appreciate all the answers!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in