Results 1 to 5 of 5

Thread: PS3 Slim with Rogero FW help?

  1. #1
    ps3amateur Guest

    PS3 Slim with Rogero FW help?

    Hi guys,

    This is my first post, so please accept my apologies if I don't make total sense as I'm very new to the ps3 scene. I have got a ps3 slim from someone which already has a rogero cfw on it. It also has a large internal (640gb) and an external (120gb) hard drive - both with many game backups. For now, I have a few questions:-

    1. Some of the backed up games don't work - i.e. if I run them, I either get a black screen or they may give an error - How can I find out how to fix these? For example GTA

    2. What is the current cfw/Recommend latest cfw?

    3. Is it safe to go on PSN? If so, how?

    Thanks very much guys!

  2. #2
    lionsfan420 Guest
    Your best bet is to upgrade to 4.46 rogero/cobra mix cfw. Also it would be 99.9998% compatibility rate using that fw along with turning all your games into iso's. GOOD LUCK!

  3. #3
    windrider42 Guest
    Check you system Settings for what CFW you are on already.

    As for Black Screen games, you may need to update them to play or choose BD Mirror in Multiman. Have a disc in PS3 as well. If error code, please post.

    Really for CFW, most can still get by with Rogero latest. I still do.

    No, it is never safe to go on PSN, or online. You do so at your own risk. But if you must decide to choose yes, then use PSN patch by kokotonix

  4. #4
    ps3amateur Guest
    thanks lionsfan420 and windrider42. I do apologize for replying late. First of all here are my current details:-

    ROGERO CFW 4.40 V1.03
    MULTIMAN 4.30

    I've had a look at every single full game in MM and the only ones now not working are:-

    BattleField 3 (Black screen before title) - installed on internal hdd - already tried choosing bd mirror and/or internal options

    Prince of Persia (Says "Game Data Corrupt") - - installed on internal hdd - already tried choosing bd mirror and/or internal options

    So how can i fix these and how do i upgrade to the latest CFW and what version?

    Thanks very much again.. any advice guys?

  5. #5
    windrider42 Guest
    Update to latest multiman >

    Update to Rogero 4.46 v1.00 in XMB with no problems >

    As for your Prince of Persia, you may need too delete previous game data, and try again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts