Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.

But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

  1. #1
    mkahar Guest

    PS3 Slim new blu-ray drive not working help?

    I have a 160gb slim the blu ray drive which stopped reading disks so bought a new one and replaced it with the old one, I didn't need to swap the logic boards because its built into the motherboard. Only to find out this new drive didn't work, so opened up my brothers 160gb slim (same model) and used his blue ray drive and this didn't work both drives work in his console but not mine.

    When any of the drives are in my slim the disc spins for a second then stops and I can see the laser working (I opened the blu ray lid to see it working). Anyone know how to fix this or have the same problem? Updated to 4.21 and it still didn't fix it.

    Thanks in advance guys.

  2. #2
    sharred Guest
    The ribbon or the socket of the ribbon is damaged.

  3. #3
    mkahar Guest
    Ribbons work as they worked on my brothers ps3. Any way to check the socket? It doesn't look damaged, looks the same as my brothers slim.

  4. #4
    raddog Guest
    this would never work for you, you have to remarry the drive to your ps3... and now i see that you are on 4.21fw you can't remarry on this fw, you need to be on 3.55 to do this.

    there is still hope, you could get a flasher to downgrade your ps3 to 3.55, then remarry and then update it back to 4.21, that's if you don't want to stay on 3.55 and if you don't want to invest in one just send it to sony. hope this helps.

    Also from svenmullet: If you have a BD drive that won't read discs due to dead laser, you've been out of luck as far as booting certain backups that require a disc inserted, right? Well, on MFW 3.55 DEX, there is a way to circumvent this. Set "Blu-Ray Disc Access" to "BD-Emulator (USB)", set "Boot Mode" to "System Software Mode" and make a working BD Emulator drive on a pendrive.

    Install a small game to it (doesn't matter what the game is, it just needs to be a valid drive that the PS3 recognizes and mounts on the XMB. I used Fallout3 ~7GB) Boot Multiman and load a game as usual. It replaces the BD-Emulator icon with the game you selected, and the game should boot fine without a BD disc inserted!

    In Target Manager, connect to your target (the PS3), then right-click on it and click "Set File-Serving directory (app_home/)...". Navigate to your backups folder on your PC, and select one of the base directories (with PS3_GAME and PS3_UPDATE folders, and PS3_DISC.SFB) and then navigate to app_home/PS3_game icon on the PS3. Voila!

    The game icon appears there. of 15 or so game backups, I've not gotten any to actually boot properly, but a few show promise; Fallout 3 gets to the "Installing Tropies" screen, then locks up, and Battlefield 3 (after editing the PARAM.SFO to 3.55) gets to the Loading screen but stays there and won't boot. I think with a bit of R&D, this will be the backup loading of choice on DEX. (network loading of game backups)

    From Mistawes: Interesting findings svenmullet, I got games to work from Target Manager.. They need to be converted to Fself's and then they work fine. There are a couple that won't work for me, but I think it's because I didn't get all of the sprx files.

    When there are .sdat files, they also seem to not work but maybe it's just coincidence.

    One of my testing games was Race Driver : GRID, wouldn't work until I decrypted the EBOOT.BIN hex edited DEV_BDVD to APP_HOME and then fself it. After that, it worked great!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Log in