Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.

But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

Page 1 of 2 12 Last
  1. #1
    swantsong Guest

    Ps3 Red screen help?

    Hi eveyone,

    My ps3 is stuck in some sort of loop. I entered the restore menu as I have the red screen of death happeneing right now. I tried all of the options and they all kick me back to the red screen of death. The system update function tells me to install 3.56 or above. I tried one version of 3.56 I found and it says data corrupted.

    What should I do now? I'm not trying to jailbreak... just would like to use it normally again.


  2. #2
    SinnerShanky Guest
    download ofw 3.60 from sony website... Install it.. i dont think it'll show data corrupted then...

  3. #3
    swantsong Guest
    Ok I'm going to try that now. It's an 80gb Fat ps3 btw. I've read online that a lot of this model seem to suffer from the red screen of death issue. Anyone know why?

    Ok I downloaded the OFW 3.56 and 3.60 and neither one worked. Both said data is corrupted. I put them on a usb and into PS3 -> UPDATE - > .pup

    Is this PS3 folder supposed to be the only file on the Usb Stick or can it have other files on the root of the USB?

  4. #4
    madmax69 Guest
    You state it's red screen , can you explain more what happens , ie when you switch your ps3 on does it start updating and then go to red screen ? When does it say data corrupted ?

    Also when 3.56 came it it bricked alot of consoles and they had to release a second version of 3.56 if your not jailbreaking and it's ofw why don't you just call Sony to resolve for you incase you make matters worse.

  5. #5
    cackalack Guest
    only very lucky people come back from RSOD no point phoning $ony as its an 80 gig and obviously out of warranty, they'll just tell you to pay 130 plus your console for a reconditioned replacement, for a chance of getting it back on you'll need to install brand new hard drive formatted to FAT32 and install latest 3.60FW.

    I've dealt with around 10 80 GIG RSODs and got 2 back up and running with that method, if it fails you've got a bluray drive thats worth selling get that put on ebay and put money towards a new console.

  6. #6
    madmax69 Guest
    Yeah but if the firmware caused the red screen doesn't matter if out of warranty they will repair.

  7. #7
    SinnerShanky Guest
    try to put some other hdd and switch it on... it might help. otherwise i would suggest to call sony and tell them that the fw update caused this problem and you want a free service. Don't say that it would be great if they gave him a free service.. Be to the point and bluntly say that you want a free service.

    If they accept, well and good, otherwise ask the costs... see how much your console is worth right now on ebay and see how much it'll be worth after repair. If the worth after repair is more than the repair costs plus worth now then go for the paid repair otherwise its your call and you gotta decide. In the meantime i'll research some more on the rsod and try to give you a solution...

  8. #8
    swantsong Guest
    The Red screen appears as soon as the ps3 is turned on via the power touch button. You hear a doot sound, but never see the initial ps3 screen or violin sound that happens with a normal startup.

    The data corrupted happens when I try to update firmware via the recovery menu. I can get to the recovery menu everytime, but I tried all of the options and none of them work. They all return me to the red screen within a minute of selecting them. Rebuilding the database goes from 0 to 100% but then still goes to the red screen.

    I will try a different HD and will post the results.

  9. #9
    madmax69 Guest
    Mat be worth putting into factory mode and downgrading to 3.41 when you put USB stick in with the self files and switch on should do the trick this worked with mine however this because I was messing with CFW would only attempt this if Sony won't repair

  10. #10
    swantsong Guest
    Ok I formatted the HD, but now it is saying it can't access the HD. What would cause this?

    Now there is no more red screen of death, and it boots to a black screen asking for you to update to 3.56 or newer. I just tried 3.56OFW and it gave the data corrupted message. Are the hard drive and the usb stick supposed to be formatted in Fat32? Does this matter? I'm about to try the 3.60 and will post results afterwards.

    ok I tried 3.60 OFW and had this result: The data is corrupted (8002F2C5)

Page 1 of 2 12 Last

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Log in