PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!

  1. #1

    [UnAnswered] PS3 Red Screen Error help?

    Dear all,

    Any one knows how to solve the PS3 Red Screen Error?


  2. #2
    Join Date
    Feb 2010
    How did this come about?

  3. #3
    I donno exactly.

    But all what I know that is the a red screen appears after running my ps3.

  4. #4


    Did you try running any homebrew before this happened? or has this happened on an unhacked ps3?

  5. #5
    unhacked fat ps3..

  6. #6
    Try going into service mode and restoring the file system on the ps3.

    If that doesnt work, go into service mode again and try restoring your firmware.
    Last edited by demondor; 02-03-2011 at 07:07 AM Reason: grammatical error

  7. #7
    Join Date
    Nov 2010
    this has recently happened to me by learning the hard way, i tried to install firmware in factory mode prior to reading instructions before attempting oh dear, major learning for me here.

    At the moment whenever I switch on the ps3 it comes up installing update 0% after a second or 2 red screen comes up with serious issue in a 100 languages.

    I can't find a solution to this, tried with dongle, trying service mode everything but just gets to the red screen. Still under warranty but not sure if they will know i had homebrew apps.

    If anyone has any advice would be greatly appreciated.

  8. #8
    Join Date
    Nov 2010
    I rectified mine by coping the level 2 self file to a usb plugging in to far right usb port and powering up , all ok now.

  9. #9
    Join Date
    Nov 2010
    I'm experiencing now is a red screen on the PS3 Fat, I do not understand the composition downgrade files in the USB.

    PS3 -> UPDATE -> lv2Diag.self + UPDATE.PUP right or wrong... please help me.
    Last edited by Taufik; 02-07-2011 at 06:39 AM Reason: Automerged Doublepost

  10. #10
    Join Date
    Nov 2010
    If your downgrading , you need file 1 in root of usb stick (not in any folder) + the modified 3.41 pup in the stated folder .

    if your coming out of service mode you need file 2 in root of usb stick (not in any folder).

+ Reply to Thread
Page 1 of 2 12 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts