Sponsored Links

PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!
Sponsored Links
Sponsored Links
Results 1 to 8 of 8

  1. #1
    Registered User Gazza85's Avatar
    Sponsored Links

    [UnAnswered] PS3 issues, anyone help?

    Sponsored Links
    Hi All,

    A friend of mine dropped his PS3 off to me as it has recently stopped playing DVD's. This is in any form i.e, PS2 games, Movies, Data etc. (This has only occured since he updated his firmware to 1.81, although think this may just be a coincidence). When a DVD is inserted, it spins once or twice but nothing on the XMB loads. I get the small icon in the top right corner that a disc is trying to load but nothing ever does and the icon disappears.

    I assumed it would be the laser or something within the BRD as CD's and Blu Ray films/games play and load fine.

    I stripped the console down and changed the laser from a working machine, tested the new laser with a PS2 game and it still does not load! I then tested the laser I thought was working incorrectly in the other PS3 and that loaded PS2 DVD's fine. :??

    I tried changing the HDD just to see if his 120gbdrive maybe causing it to play up but there is no difference with a 60gb.

    A couple of facts:

    The machine not loading DVD's is JAP 60gb model. (1.81 FW)
    The machine that donated the laser is PAL 60gb model (1.70 FW)
    On the Jap machine he has the switch installed to play backup PS2 games/PAL PS2 games.

    Is there anything else I can swap to try and find what the problem is?

    Pic attached to show what I have changed. Thanks in advance, i thought a laser change would of cured this but guess not...

    Attached Thumbnails<br><br> Attached Thumbnails


  2. #2
    Sponsored Links
    Can it be maybe the cabling/wires to bluray drive got bent? Did u try swapping out the entire bluray drive?

  3. #3
    The entire blu ray drive seems to be married to the console it came from which is why Ive had to revert to swapping individual components from another drive.

    Checked all wires and everything seems intact, running out of ideas to be honest...


  4. #4
    it couldnt just be a firmware update issue could it? I mean, maybe something is a lil corrupted or something. 1.82 comes out pretty soon maybe just give it an update and hope for the best? It doesnt seem likely that it would be so simple but worth a shot if all else fails.

  5. #5
    Have thought about that myself VendeTTaa. If I cant think of any other ideas it'll be my last shot anyway. Thanks

  6. #6
    Did you try removing the switch? The 1.81 firmware might have some bytes that prevent that kind of method... Just a guess, I discovered ps3 proxy only a few weeks ago, so you can call me a noob on Ps3!

  7. #7
    Did you try removing the switch? The 1.81 firmware might have some bytes that prevent that kind of method... Just a guess, I discovered ps3 proxy only a few weeks ago, so you can call me a noob on Ps3!
    Will be removing the switch after acouple of little things ive come across today/yesterday. People have this running on 1.81 so I cant think why it would just effect this one...

    Got abit of an update now. I changed the main circuit board underneath the blu ray drive (see attached pic)

    And DVD's would now load again. I could load original PS2 games again and use the swap trick with the switch. This lasted about 10 minutes and then the same problem re-occured. I swapped that board over again with another one and it worked fine. I tried the board that wasnt working in another PS3 and it did not work so something dodgy is happening to that particualr board within the BRD when using this swap method. I just hope it has nothing to do with the switch method and it seems a coinsidence that using this is blowing something on the circuit board because otherwise alot of them will start breaking down soon.

    I just cant believe though how soon the 2nd board broke down after only doing 3 or 4 swaps. The thing was though I wasnt getting a backup PS2 game to load. I'd get the PlayStation 2 splash logo and then it would lock up with a black screen...

    Any other suggestions?

    Attached Thumbnails<br><br> Attached Thumbnails


  8. #8
    I had a day ago the same thing u did. A day ago i tried the swap trick mod. All are working fine... The next day i made some swaps... Suddenly the drive stopped to take in disks. The blue led lights up indicating that a disk i going to be put in, but the motor doesn't work. If you manually insert the disk using the external power to function the motor the disk gets in normally but it will not spin.

    I rebuilded and checked the drive several times but it doesn't work again. Gazza85 has had the same prb, and here the facts:

    -Because of the external power (i used only 1.5V) something has happens to the the main circuit board under the drive (see attached files, taken from Gazza85 thread)
    -I don't think that the prb occurs after 3-4 swaps but if you overdrive the motor
    -The prb happens as far, only on JAP-made consoles
    -Happens on FW 1.60 and up so far
    -Happens only if ps3 is running?!

    And the NICE:

    PS3 works with and without the BRD. No bios check. neither an error.

    The BAD:

    Can't play RFOM not watch DVD's
    No where to find a replacement (notice that are replacement of the Blu-ray lens)


Sponsored Links
Advertising - Affiliates - Contact Us - PS4 Downloads - PS4 Forums - Privacy Statement - Site Rules - Top - © 2015 PlayStation 4 News