Results 1 to 4 of 4

Thread: PS3 doesn't want to turn on help?

  1. #1
    spennacchione Guest

    PS3 doesn't want to turn on help?

    Hi guys. I had removed my flasher on my Ps3, when i had finished the operation i observed that my ps3 didn't want to turn on...there was no red light and no "bip sound". I opened it again and i observed that the cable who colleague motherboard and accension bord (On/off Button and Eject button) was broken.

    Than i went to my friend and i asked him to lend me his ps3 slim, i opened it and i replaced my cable with his cable, than my ps3 turned on!

    I bought new cable and i putted again his cable on his ps3, and i connected the new cable at my motherboard. When i tried to turn on his ps3, i discovered that it don't work, his red light don't appear and when i press the power button the ps3 do 3 beep but don't want to turn on.

    When i tried to turn on My ps3, i discovered that it don't work, but mine don't do 3 beep and the red light don't appear. I'm hopeless, please help me (And sorry for my bad english)

  2. #2
    racer0018 Guest
    What are the model numbers of these systems, are they both slims. If so once in a while you can look at the cable and see that there are parts of it broken. And you could cut off the broken parts and then try it agains and this might work. Now the once that beeps three times makes me worry cause it is some other problem with that one.

  3. #3
    spennacchione Guest
    My friend's ps3 is a Cech-2004B
    Mine is a Cech-2504B

    But i bought a new cable, i replaced old and broken cable with a new cable, but my ps3 don't work. And what is the problem for the 3 beeps?

  4. #4
    JeoWay Guest
    I had this same problem. The Red Light not appearing is due to a few possible reasons:

    1.) The cable that is connected from the Power Button/Eject Board to the Motherboard is broken (I had this once)
    2.) The Power Supply Unit (PSU) is dead (maybe the fuse blew)
    3.) The ribbon from the Blu-Ray Drive is not connected.
    4.) The Power Supply isn't connected to the motherboard.
    5.) The console may not have enough power or is overheated (3 beeps)

    I would order a new cable (1st reason), ask someone if their power supply unit works and if you can use it. Make sure Blu-Ray Drive ribbon is connected and not broken. Make sure PSU is connected to motherboard properly. Also check if the thermal paste is dry, etc. You should get what I mean

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts