Sponsored Links

PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!
Sponsored Links
Sponsored Links
Results 1 to 10 of 10



  1. #1
    Contributor Naota753's Avatar
    Sponsored Links

    [Answered] PS3 Disc only reads after a reset help?

    Sponsored Links
    I have a Slim CECH-20XXA (I think that's the model number) that had a ripped Blu-ray power cable. Bought a replacement and fixed it, but then PS3 failed to accept or eject discs properly. After a manual reset of the drive it finally works, except the PS3 refuses to load the disc.

    Did a file restore and the disc could be read just fine. Had a good marathon session of 4+ hours. When I ejected the disc, the XMB didn't recognize that and still displayed a disc icon for the game. Clicking it gave a "disc cannot be read error". Don't remember the code but I don't think it's relevant. Did a few tests with file restore and came up with this:

    - Tried file restore with no disc in the system. No discs will be read.

    - Tried file restore with a disc in the system. Disc will be read perfectly fine, even during extended play, until the game is ejected. Then no other games will be read.

    Haven't tried anything but game discs. Doesn't seem to be any physical problems. Even tried a full factory restore and didn't work. I can only guess it's some kind of software issue but I have no clue on what to do. PS3 is a fully updated basic slim, no CFW.
    Best Answer - Posted by metzen:

    The controller board is married to the drive. If you have a spare controller board, same model, you could get it remarried and then see if it reads discs properly. It will not read properly if its not married.

    The controller board is just that. The board which controls I / O Functions for the bluray drive.

  2. #2
    Sponsored Links
    If you reinstall your firmware, e.g. Update via USB stick, and you still have the problem, then it must be a hardware problem.

  3. #3
    So just take the latest PS3 update from Sony's page and reinstall it?

    And assuming it IS a hardware problem, what could it be? Laser and cooling work perfectly fine. MB ribbon cable still intact and power cable was just replaced.

  4. #4
    Do a Restore Factory on PS3 but this will wipeout your entire data and configuration on your PS3, leaving it as like a day1 PS3.

  5. #5
    I did that already. No change. However, I forgot to test the disc reading before I restored my files from a back up.

  6. #6
    Quote Originally Posted by Naota753 View Post
    So just take the latest PS3 update from Sony's page and reinstall it?
    I would re-install the same firmware you are on.

    But if you are above 3.55 or not on any CFW, then I guess the latest firmware will do.

    For hardware problems though, maybe youtube can help you

  7. #7
    Assuming it's a hardware problem, what could it possibly be?

  8. #8
    If it is a model 2xxx then it might be the control board that sits under the Blu-ray going bad. Or something else. I could tell you what I would but you don't have the tools to try it. If it were me I would take a Blu-ray that I have and marry it to it and see if that would fix the problem. Thanks.

  9. #9
    What exactly does the control board do?

    I'm convinced it's a software issue, but I'm no expert. Are there any tests I could do to help single out the problem?

  10. #10
    The controller board is married to the drive. If you have a spare controller board, same model, you could get it remarried and then see if it reads discs properly. It will not read properly if its not married.

    The controller board is just that. The board which controls I / O Functions for the bluray drive.

 

Sponsored Links
Please Register at PS4News.com, Login or Activate Your Account to make comments on the PS4 News Forums. Thanks!

Advertising - Affiliates - Contact Us - PS4 Downloads - PS4 Forums - Privacy Statement - Site Rules - Top - © 2015 PlayStation 4 News