Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.

But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

  1. #1
    Wastedone Guest

    ps3 break v1.1 identification help?

    So I picked up this device attached some images. It does jb my device but I've been trying to figure out if it can be updated. Tried the update from the ps3break site. Cannot get device to go into loader mode when pushing the button. Tried device in 2 different pcs running different os's.

    On windows 7 x64 machine, device just keeps disconnecting and reconnecting USB not recognized. Device lights up green when I plug it in then goes out. Pressing update button lights up the green light again but goes out when no longer pushing. Tried many different ways of plugging in and button pushing timing.

    On windows xp machine, device plugs in and comes up usb device has malfunctioned and shows up as unknown device. On this machine when pressing the button green light comes on but nothing more. Once again tried numerous methods of button pushing, also many reboots and driver uninstalls. Tried many different update methods on this device but nothing works.

    Just curious if someone might recognize the chip on this board and maybe shed some light on my situation. There are no markings on the chip which has 24 pins or the board which only has c1, c2, c3, jp1, u1, s1, d1 and r1.

    Thanks for any help you might have on this. I have a feeling I have an unupdatable clone and should just quit trying.

  2. #2
    oVERSoLDiER Guest
    There have to be an code on the board like "USB-A6-V1.0".

  3. #3
    Wastedone Guest
    There are no markings on the chip which has 24 pins or the board which only has c1, c2, c3, jp1, u1, s1, d1 and r1.

    That's why I'm stumped.

  4. #4
    elser1 Guest
    i noticed the box doesn't have the truth enquiry sticker on the front.. could be fake?.. that's why doesn't update?

  5. #5
    JedTanner Guest
    I have to agree.. big possibility of a fake one. Check their website (ps3break.com/truth). They have a comparison between the authentic and the fake with pictures on how to spot the difference. That sucks if it's a fake!

  6. #6
    jetli68 Guest
    i got the ps3 break 1.1 and it has got the truth enquiry sticker on the front and bar code on left not in the middle. i have updated mine with no probs i think you have got the fake one m8.

  7. #7
    Wastedone Guest
    it is a fake from what i see. no sticker, box is the wrong size. Other than that, everythign else checks good. Pre loaded jb and update button not working. I'd put money that it is indeed fake.

    Here's what I'm looking for. Is there a driver that will make this device recognizable by my pc so I can flash psgroopic on it? It does indeed look like a pic chip.

    No more buying mod chips on the sidewalk. lol.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Log in