Page 1 of 2 12 Last
  1. #1
    Join Date
    Oct 2012
    Posts
    10

    Confused PS3 4.20 Firmware update help please?

    Hi all. Here is my problem. I got a ps3 recently from a yard sale and when I took it home and hooked it up I got a screen that says: The system software cannot be run correctly. Press the ps button to try to restart the system. If the system cannot be restarted, you must reinstall the system software.

    Connect storage media that contains update data of version 4.20 or later, and then press the start and select buttons at the same time, For information on how to obtain update data, refer to the sce web site for your region.

    When I restart I get the same message. So I download version 4.20 copy it onto a usb flash drive put it in ps3 and get a screen that says: No applicable update data was found. Insert storage media containing version 4.20 and so on.

    What am I doing wrong please?

  2. #2
    Join Date
    Apr 2005
    Posts
    24,702

    Lightbulb

    You may not be putting it in the correct directory path on the USB stick... it should be in PS3/UPDATE/PS3UPDAT.PUP (note the CAPS used for the folder names)

    More details are here as well: http://us.playstation.com/support/sy...date/index.htm

  3. #3
    Join Date
    Oct 2012
    Posts
    728
    create a folder on the usb called PS3 in that folder create a folder called UPDATE, and put the pup file you downloaded into that folder then try again.

  4. #4
    Join Date
    Oct 2012
    Posts
    10
    O.k. guys here's what happened, I formatted the flash drive fat 32, created a folder "PS3" inside of that another called "UPDATE" inside of that another called "PS3UPDAT.PUP". I extracted the ps3updat.pup rar file that I downloaded into that. Tried again and got same results. What now??

  5. #5
    Join Date
    Feb 2008
    Posts
    1,186
    Try a different USB device. Or Download 4.25 from the official Playstation site.

  6. #6
    Join Date
    Sep 2007
    Posts
    53
    not another folder called PS3UPDAT.PUP!!!

    you have to extract your file in the UPDATE folder. So the "file" PS3UPDATE.PUP should be in the UPDATE folder.

  7. #7
    Join Date
    Oct 2012
    Posts
    728

    [Register or Login to view code]

    this should work.

  8. #8
    Join Date
    Oct 2012
    Posts
    10
    Ok I started all over again. New flash drive, new format, new download, new folders PS3>UPDATE>extracted ps3_updat.pup. Same results, turned the thing of and back on and got file system is corrupted it will be restored. The thing is now apparently stuck at 37%. any ideas?

  9. #9
    Join Date
    Feb 2008
    Posts
    1,186
    I hope you don't have it as you do above.. It should be PS3UPDAT.PUP NOT ps3_updat.pup

    But if you do have it correct and still same error. I wonder if somebody tried to downgrade this PS3 or something. Does it only say 'file system corrupted it will be restored' or is there an actual error number as well, such as 800xxxx

    I would take the hdd out of ps3 its not hard, and then format it on your pc with NTFS. Then try updating again.

  10. #10
    Join Date
    Oct 2012
    Posts
    10
    It only says "file system corrupted it will be restored" there is no error number. Then it does the restoring thing at the end of that it reboots and again I get the same message "file system corrupted it will be restored" and starts again. I don't think it's restore thing is working or something.

Page 1 of 2 12 Last

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in