1. #1
    Join Date
    Jun 2011
    Posts
    39

    PS3 3.70 Corrupt Data Issues help?

    Hey all,

    Bit of background info: I've been fiddling with my 80GB CECHG02 running 3.70 using an Infectus 2 and I need to do a fresh 3.70 install. I cannot downgrade using the 3.6x method yet, but I'm getting ECC errors in one of my flash chips with the original 3.70 image. The ECC errors are at the same page every time. I want to do a fresh install of 3.70 to see if the flash is stuffed, the Infectus is not soldered correctly or if the image is corrupted.

    Problem: If I try and do an firmware update from the recovery console, no matter what I do, it keeps telling me that the "data is corrupted" after it copies to the HDD. I've tried multiple USB pens, downloaded the 3.70 (official) numerous times; all to no avail.

    Has anyone else had problems with a 3.70 install from a USB drive?

  2. #2
    Join Date
    Oct 2008
    Posts
    319
    The ECC errors will definitley be caused by just the one wire that isn't quite 100% solid. Also, check your infectus chip for any solder splashes etc as you sometimes get them off the pads.

    Are you soldering to the TSOP, or using the alternative points?

  3. #3
    Join Date
    Jun 2011
    Posts
    39
    I've soldered directly to the ICs. I've checked on the Infectus side to make sure there are no shorts, but I probably need use the microscope again to make sure. I also want to shorten the leads a bit as they may be too long.

    It might be a week or so until I can get the PCBA into the lab as I'm changing jobs on Thursday. The new job (place I've worked at before) has an awesome setup, but I don't want to drag my PS3 in on the first day

  4. #4
    Join Date
    Sep 2011
    Posts
    2
    i have this problem on 3.56 fw help me also

  5. #5
    Join Date
    Jan 2010
    Posts
    1,345
    I don't think this will help you, because you have an 3.70 error, but you may want to look at this nevertheless, because it's still interesting and the topic was the unbrick of the Waninkoko v1, which "destroyed" a lot of NAND's ( http://www.ps4news.com/forums/ps3-gu...tml#post354632 ).

  6. #6
    Join Date
    Jun 2011
    Posts
    39
    oVERSoLDiER - I've read that. I'll have a play around and see how 3.70 differs.

    The problem I have now is not to do with the flash ICs, rather I keep getting a "corrupt data" message after the PS3 copies the PUP from a USB pendrive to the HDD. When it restarts, it cannot read the PUP to copy it into the flash ICs.

  7. #7
    Join Date
    Jan 2010
    Posts
    1,345
    If the *.PUP has the right checksum and tried different USB-Devices, you may should also try a different HDD. These parts are easy to change and won't cost you much. Maybe it helps you.

  8. #8
    Join Date
    Jun 2011
    Posts
    39
    You might be onto something there... I fixed a slim last night that had a dodgy HDD. It would copy over the firmware, but stall for a bit at 99%. Then it would ask for a valid version of the firmware and keep looping like this. With a fresh, formatted HDD it had no problem. Would not accept the original HDD, even after I nuked the partition table. Should have been obvious, seeing as some nasty noises were emanating from that HDD.

    I'll grab a new HDD on my way home from work and try this same technique on my ol'Infected-fatty.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in