Results 1 to 8 of 8

Thread: PS3 and 3.0 Ext HD help?

  1. #1
    Krisdog Guest

    PS3 and 3.0 Ext HD help?

    I've been trying for the last 3 days to connect my Western Digital MyBook USB 3.0 2TB external drive to my ps3 slim to no avail.

    I've went through hell and back so I wonder if it is even possible? Is the ps3 capable of backward compatibility with this drive?

    I know many people have connected a 2.0 usb external to a ps3 but I've googled and asked tech friends,game owners, Sony PS3,WD, Seagate,Buffalo,Adata.You name it.

    Yes of course I formatted the whole drive (partition) 935GB into FAT32 using Various software programs; SwissKnife, Acronis, Partition Wizard they all show after completion that the drive was formatted to FAT32.I even tried making folders; VIDEO,PICTURES,MUSIC and still no go.Also formatting the entire drive.

    Is there something I'm missing? Is it a chipset issue or a host controller defect on ps3's end? The funny thing is it will read my FAT32 Supertalent usb 3.0 16gb flash drive so I dont know if the flash turns into a 2.0 usb read that ps3 recognizes but it can't do that with the build of an external drive, maybe bc it's just a WD black or blue cavier sata with a controller laned into 3.0 usb ports inserted into a tower.

    If anyone has had success with any of the USB 3.0 external drives please let me know the amazing fix. I even thought there may be a difference with the usb 2.0 and 3.0 cables and I would have to switch to a 2.0 to connect to ps3. I'm not leaving any stone unturned.

    I contacted sony! ps3 and they escalated it for the next meeting, so they say... WD has no clue and will look into it... Seagate tech support told me right away it isn't supported but didn't say why bc I had to convey questions to the girl on the phone.Buffalo didn't know, so I contacted various retailers in Canada that sell the drives to see if there was any feedback from customers or tech savvy employees.No one seems to know.Yet this could be a simple fix or it might be impossible with ps3's current setup and may be fixed if/when ps4 is released.I doubt a patch or firmware can fix this but you never know.

    It would be interesting to see if the ps3 will recognize a SSD in a usb 3.0 enclosure.I have a OCZ Agility 2 SSD new and may try this b4 I install it with my original intention as internal for Windows 7 64 bit OS and media.I also bought an ASUS U3S6 card that comes with 2 usb 3.0 ports.

    So once again, thanks for anyone that has had success with these drives and I'll be sure to post any information I receive.

    regards, Krisdog

    ps. bought same drive with 2.0 data cable, worked perfect.
    Sad thing is 3.0 is the standard SOON. and ps3 usb slots only read at very low gb!

  2. #2
    barrybarryk Guest
    first of all look up backwards compatibility in a dictionary, the ps3 definitely 100% isn't backwards compatible with USB 3.0 although your USB 3.0 HDD is backwards compatible with the PS3's USB 2.0 controller.

    format the drive to a 1.5TB or less fat32 partition or 2 1TB partitions if you like and PS3 will pick it up.

    backwards compatibility is part of the USB 3.0 standard so you can be sure the problem has nothing to do with the PS3.

  3. #3
    severusx Guest
    What barrybarryk says is correct. Your issue is not USB 3.0, as all 3.0 devices will work in 2.0 mode. I suspect that the drive is simply too large for the PS3 to use it. Most 2TB drives use a 64k block size that requires O/S support and/or special jumper settings on the drive for it to be recognized. My guess is that the the PS3 O/S does not support that block size and that the jumpers on the drive inside the enclosure are not set to drop the block size down. Does the drive work correctly on your computer?

  4. #4
    dorlandow Guest
    so glad i didn't pick up one of those drives. I'd be on the same boat

  5. #5
    Ogdrastik Guest
    i bought a wd 1tb my essentials ext hdd back in November for the purpose of baking up games.. problem was it did not read on the ps3.. after some extensive research i noticed there was a partition on that hdd that i could not format.. it was about 15 GB or less i cant remember anyways i found out that since last year all wd ext hdd have this partition in a udf format and low and behold it is the first thing the ps3 sees when you plug it in.

    meaning a no go you cannot use a wd ext hdd on ur ps3 if you have this partition on it.. best thing i could tell ya is take it back and get a seagate.. at least they let you take off their backup sofware which is on the hdd from the factory.. i bought 3 of them the 2TB usb 3.0 on black friday last year and each and every one of them are seen by the ps3... hope this resolves things.


  6. #6
    Krisdog Guest
    To the people here that understand that I was just trying to share this issue I had, and maybe save someone my trouble. And at the same time see if I was over looking some thing.

    Severusx, thanks! That makes perfect sense. Unfortunately I returned in for the 2.0 already. Important thing is that its backed up and now I have your knowledge.

    Ogdrastik, thanks for the tips from your experience.

  7. #7
    barrybarryk Guest
    i think you may have missed the point, what i meant was the ps3 will never be usb 3.0 compatible it would take a hardware upgrade not a firmware upgrade but every usb 3.0 device has to be compatible with usb 2.0 devices to be called usb 3.0 as its part of the standard.

    I said to format the drive again to make sure you were only using fat32 partitions as alot of externals come with hidden partitions to install their desktop backup software on your pc without having to include a disc.

  8. #8
    ps3haze Guest
    I think you can solve this. I had a WD 1TB for a while (before my PS3 and it's gone now) and I was able to remove that partition and use it with my PVR.

    The PVR wouldn't use it at first but I used windows device manager to delete that extra partition and then I reformatted and it worked for me.

    Try using Disk Manager on windows or another partition util to redo that drive. Or you can try the WD util to write zeros to the drive, then initialize in disk manager, after that create a new fat32 partition or 2 under 1.5 TB in size.

    WD disk util here:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts