Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.


But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

  1. #1
    riotDX Guest

    PS2 Classics fan issue help?

    Greetings everyone, I'm relatively new to the PS3 Scene since I finally got around to picking one up after I saw that PS2 games were now (relatively) easily accessible on all jailbroken PS3s.

    That said, I seem to have an odd issue with any of the PS2 Classics that I have tried. This includes both official Classics downloaded from the PSN Store myself, and games that I have ripped and converted to Classics.

    Long story short, every time I open any PS2 Classic, the fan immediately kicks up to the highest speed which is incredibly loud, and stays there until I turn the system off. The only time the fan even reaches that speed is immediately after I boot up any PS2 Classic.

    I haven't been able to find any forum posts here or elsewhere addressing either complaints of or fixes for this issue, so I can only assume that it is a software glitch unique to my system. I know I could replace the fan with a quieter, more efficient one (and I do plan to do that at some point), but does anybody know what could be causing this or have a way around it?

  2. #2
    JeoWay Guest
    I would try re-installing your current Custom Firmware or try a different Custom Firmware.

    If that doesn't work, check and see if your console feels REALLY hot. Maybe that will resolve your issue

  3. #3
    riotDX Guest
    Well, it does the same thing when I go into a PS2 Classic after just having turned the console on, and I doubt it would get that hot that quickly. I certainly will try reinstalling my CFW.

  4. #4
    JeoWay Guest
    Okay, I would also suggest formatting the HDD or doing a full restore if that doesn't resolve your issue.

  5. #5
    riotDX Guest
    Brilliant. Instead of just reinstalling though, I updated from Rogero 4.41 to 4.46 since that just came out. Worked like a charm!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in