Results 1 to 6 of 6

Thread: PS Jailbreak 2 Problem?

  1. #1
    Razorick Guest

    PS Jailbreak 2 Problem?

    Hi there folks!

    Yesterday i bought a JB2 for my ps3 but im having some problems with it. I plug the JB2 in my usb1 and i press reset but the JB2 led just flashes a green light and then it turns off. I alredy tried to upgrade hermes and the upgrader but with no success.

    If someone know something about this error and how to fix it i would be very grateful.

  2. #2
    JedTanner Guest
    Hi there! What is your PS3's current firmware?

    If you are on 3.50, the JB procedure will not work; It only works on 3.41 or below. Assuming you are on 3.50, you may need to downgrade it to 3.41 first. Check this out.

    If you are on 3.41, ensure your JB files and upgrader are not corrupted. You may want to download another set and do another update just to make sure. Also, there is a proper procedure for JB'ing your PS3. If you're using a slim, you need to remove the power cord, plug in your JB2 device, plug in your power cord then press Power and immediately press Eject. For Fat, you just need to turn off the switch at the back, plug in your JB2 device, press Power and immediately press Eject.

    Hope this works for you!!

    Edit: For Fat, turn switch off at back, plug in your JB2 device, turn switch on then press Power and immediately press Eject.

  3. #3
    hongman Guest
    For my slim I just turn the switch off at the plug, physically unplugging is not required

  4. #4
    Razorick Guest
    I'm doing all the recomended procedures but with no success... I already tried to upgrade my JB2 files but after i download it and plug the JB2 in my PS3, the green light blinks and then it turns off.

    I dont know if this helps to solve the problem, but a couple days ago i bought another JB2 but i sold that one. So, the JB2 that i own is the second one that im plugging into my PS3.

    And before i forget, here is the configuration of my console: PS3 Fat, 20GB, 2USB's, upgraded to V3.41, disconnected from the internet.

  5. #5
    severusx Guest
    I know it sounds like a stupid question, but are you sure you are doing it right? The dongle shouldn't light up as soon as you plug it in, since the PS3 should be powered off. Follow JedTanner's post above exactly as it says. If this doesn't work then it's possible you have a bad payload.

  6. #6
    Razorick Guest
    The dongle just flashes a green light and then it turns off.. I'll try to update the payload when i go home since its the only thing that i didn't try.

    Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts