Sponsored Links

PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!
Sponsored Links
Sponsored Links
Results 1 to 2 of 2



  1. #1
    Banned User tranvanthien's Avatar
    Sponsored Links

    [Answered] Need help about Castlevania Lords of Shadow?

    Sponsored Links
    Hi all!

    i've just bought Castlevania: Lords of Shadow asian version. It require 3.42 but my PS3 still 3.41. So what can i do to play this game ? If i update to 3.42 that mean say goodbye jailbreak. Sony is messed up. I hate them.

    thanks for any helps.

    Game ID is BLAS-50248
    Last edited by tranvanthien; 10-31-2010 at 01:08 PM Reason: Automerged Doublepost
    Best Answer - Posted by PS4 News:

    See these threads for how to run 3.42+ games on 3.41:

    http://www.ps4news.com/forums/ps3-ha...-a-114144.html

    http://www.ps4news.com/forums/ps3-ha...ak-114330.html

  2. #2

    Arrow

    Sponsored Links
    See these threads for how to run 3.42+ games on 3.41:

    http://www.ps4news.com/forums/ps3-ha...-a-114144.html

    http://www.ps4news.com/forums/ps3-ha...ak-114330.html

 

Sponsored Links
Advertising - Affiliates - Contact Us - PS4 Downloads - PS4 Forums - Privacy Statement - Site Rules - Top - © 2015 PlayStation 4 News