Results 1 to 4 of 4

Thread: JB corupted ps3 file system, need help restoring files?

  1. #1
    ChaseHammer Guest

    JB corupted ps3 file system, need help restoring files?

    Ok well the jailbreak messed up somehow on the last time i used it and corrupted the ps3 file system. When i would start it up normally it would go to the xmb background but actually had no xmb or menu. so i went into recovery mode and tryed to do a Settings Restore but that didnt help so i did a database restore and it fixed it however it basiclly restarted the ps3 like from the factory but without formatting the hdd. so i reinstalled PS3 FTP and opened it up to look at what was on the internal hdd. Everything was still there but for whatever reason teh ps3 no longer showed it on the xmb. the system found all my users and put them back but without all the save data and stuff on it.

    so my question is does anyone know how i can reenable the ps3 to see all the stuff on the hdd that is still there? i tried to find my backup for the xregistry.sys but i seem to have deleted the backups because i never changed anything on it. Im currently running a undelete program on my computer to see if i can find it but i have no other direction of i dont.

    any thoughts?

  2. #2
    DeViL303 Guest
    that sounds very bad, you are lucky you were able to enter recovery menu.I doubt undelete prog will help and will probably make it worse as every thing is encrypted and on a non standard not fat32 or ntfs, ext etc.If your program does find anything it will probably mess it up even worse as it will try to rewrite the file in a format you can see which would change encryption and it would no longer be sony signed.only option would be if there was a undelete homebrew prog for running ps3 as its the only thing that can read/write to your hard drive and keep it sony signed but it will be a long time before that kinda thing comes out.I would recommend do a full format and reinstall 3.41 as it may have left other smaller errors behind.

    just thank your lucky stars you didnt brick it.I bricked a 60gb coz of update loop, read that formating drive might help but as there was no complete firmware on Nand as soon as I formated I had a brick as the hard drive data was the only thing keeping it booting at all, your case is very different though.have you traced the issue that caused the problem? was you using awesome filemanager or firmloader? they are dangerous apps if not extremely careful.I dont think jailbreak could do this as it only patches RAM, must have been something else?

    as a quick test heres is something you could try : copy an insignificant savefile from your ps3 using filemanager or FTP, then play that game again using same profile, create a new save file in the game and then exit , go back into filemanager and replace the new file with your old one, its possible it would work as the user is the same and the encryption keys should be the same as its same ps3 and same hard drive, might be worth a try just to see if its possible to save some stuff,

  3. #3
    ChaseHammer Guest
    ok i got it about 90% to what i wanted. So well i ran System Recovery and did a Restore File System, this got back on XMB then i reinstalled FTP and blah blah like i did above. then i did a overwrite of dev_flash2 and dev_flash3 (thanks to the undelete on the usb drive lol). I got my users and psn login and stuff back but no game saves and whatknot. so i went back to recovery mode and took a chance with Restore database, it worked and i got majority of my installed stuff back but with a hitch, its installed but now all my Activations are deleted, all the stuff that requires a Owner is now disabled which sucks because cant activate it with no PSN access.

    i had to redo all the album information on everything but well its better than nothing i suppose. im working on getting a 2nd ps3 so i can turn this one into a legit machine and other for homebrew.

    so unless someone figured out how to edit activations im SOL lol. thanks for the help tho.

  4. #4
    DeViL303 Guest
    Did you make a backup of your HDD000 and all your dev_flash folders before you did this? I read a post somewhere the other day saying he had tested this and copying the licence file back over to hdd reactivated his game,ill see can i find it.obviously it would only work on same system as the file had been copied from already.As soon as I got my minimus I backed up every folder I could see using comgenies manager, over 900MB of files not including hdd00/Game folder.keeping a copy of these just incase, hopefully would be able to do a restore using these if I ended up in your situation.

    Ive a similar problem with another ps3 I have.its on 3.15 and I hadnt used it in ages ,plugged it in the other day and about 250euros worth of games have stopped working, saying they need to be activated again.worst thing is its the last surviving ps3 out of my 5 that i can activate,now im stuck without my games.I had my games on friends ps3s but they all died over the years or got sold before I could deactivate them

    edit: just reading up a bit and its not so simple ,it seems it depends on what hardware you have too, the activation files are kept on nand on older ps3s so if you upgrade hard drive on older ps3 and then restore a backup you will keep your activation files but if you have a newer ps3 with 16mb flash and you upgrade hdd and restore a backup you would need to reactivate for some reason. I hope someone figures out how to install retail psn packages or activate paid for ones at least.there is alot of people in same boat so maybe....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts