Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.


But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

Page 1 of 3 12 ... Last
  1. #1
    peanut621 Guest

    Unhappy I can't downgrade my 3.5 fw ps3 help?

    Who can help me?

    I just got a white ps3 from Hong Kong with 3.50fw installed. I use E3go try to downgrade it, but failed. The green light flash and not shut down, until I turn the machine off myself.

    What can I do?

  2. #2
    oVERSoLDiER Guest
    Do the usual way, insert USB device with the *.self and modded 3.41 and boot from it. Let the PS3 for ~5 Minutes without touching anything, it will shut down by itself.Copy other *.self file on USB device and boot from it - done.

  3. #3
    km8080 Guest
    newbie here.. want help with downgrading to older version from 3.55 (CECHG01 model). No clue about jailbreaking, need simple instructions

    - on where to download an older version and how to downgrade to 3.41 so I can install linux on it.

    Any help is greatly appreciated.

    thanks

  4. #4
    oVERSoLDiER Guest
    Look at the homepage from your Jailbreak device, there should be an introduction. Linux can just run on 3.15 not on 3.41.

  5. #5
    peanut621 Guest
    I just do this way, but failed. Green light flash and not shut down.

  6. #6
    km8080 Guest
    what are the downsides, if any. to downgrade to 3.15? I just use PS3 for BlueRay movies.

  7. #7
    oVERSoLDiER Guest
    You may loose your BluRay Movie playback when you do it and may your current data on PS3. That's all you have to be worried about.

  8. #8
    3xodus Guest
    You can't downgrade from 3.55. Sony patched it, and, there's nothing you can do with this firmware till a new exploit is released.

  9. #9
    km8080 Guest
    Is there any version out there that supports both BlueRay as well as linux and that can be downgraded to from 3.55.

    I messed up by accidentally upgrading my system just today morning without knowing the consequences of it and now looks like I am stuck with this.

  10. #10
    Join Date
    Apr 2005
    Posts
    25,073
    Quote Originally Posted by km8080 View Post
    Is there any version out there that supports both BlueRay as well as linux and that can be downgraded to from 3.55.
    As mentioned above by 3xodus there is no way to downgrade from FW 3.55 yet. When there is, it will be posted in the Site News though.

    Let's get this thread back on track now of peanut621's original topic.

Page 1 of 3 12 ... Last

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in