Results 1 to 9 of 9

Thread: help to play Assassin's Creed 1 on my jailbreak ps3?

  1. #1
    memo05 Guest

    help to play Assassin's Creed 1 on my jailbreak ps3?

    Hey guys,

    I have downloaded Assassin's Creed 1 (the GSXR version) and every time I start this game, it keeps taking me back to the XMB.

    I have tried Gaia, OM, BM, etc. Also, I tried it in external and internal HDD and nothing really happened.

    Did any of you guys succeeded playing the game ? or the game itself does not work ?

    By the way, I have the hermes v4b with Ti-89..

    Thanks in advance guys.

  2. #2
    gamesniper Guest
    The likeliest problem you have is that you programmed your TI-89 with a non-Backup playing Hex File (or w/e TI-89 files use)... Try searching for another file to install to your TI and give it a whirl.

  3. #3
    nikola989 Guest
    i thought that assassins creed is not compatible yet?

  4. #4
    Krisdog Guest
    I was able to backup AssassinS Creed 1, with a very Similar set up, I did not use the calculator though, and I was using Modchip Blackcat, Open manager v2.1g with Psgrooves v4, Hermes v4 payload.

    That has been a hit or mis game from the beginning and its failed on me a few times, just as my man that posted before me said. You may want to try a different set up. It more than likely can be fixed buy changing OPM. Hope this helps, GOOD LUCK

  5. #5
    SinnerShanky Guest
    the file you downloaded is supposedly a bad rip.. Try downloading from another source and try to play the game again as the steps you mentioned are correct to my knowledge... Download it from another trusted source and try again.

  6. #6
    memo05 Guest
    I will try another payload this time around. I will try Hermes v3b and KakaRoto PL3 and tell you if any of them work out for me.

    Also, the GSXR version of the Assassin's Creed 1 is the only version I found in the Internet. If someone here has different version, please let me know.

  7. #7
    gamesniper Guest
    Quote Originally Posted by nikola989 View Post
    i thought that assassins creed is not compatible yet?
    I don't believe that's quite true... I've DLed a version and played it for a few minutes before stopping a few weeks ago, so I don't think that's the problem...

    Well, as the people who've stated before me... You have a variety of choices to exhaust before we encounter the source of the problem...

    1. (my guess and Krisdog's approval of it) The TI-89 Installation File might not have backup support
    [Prove me wrong by telling me if you're successfully able to play any other backups]

    2. (SinnerShanky's suggestion) Bad rip? Try a new one from a more reliable source!

    Either way, it couldn't hurt to try mine out first since the file is only (most likely) 2mb (NOT EVEN!) and the quickest... If that fails you, try Sinner's choice! If not, then I don't know what to suggest...

    EDIT: Umm... You meant Hermes 4b?

  8. #8
    SinnerShanky Guest
    sniper is correct... Do these things in the order they are written.. Also i didn't mean that you gotta download some other version.. download it from some other source..! Moreover i will suggest that you put it on download.. It'll take some time to download and till then you can try the other suggestions...!

    If none of them work go with the newly downloaded rip.. If you still can't make it work go and buy a 2nd hand bluray of the game or rent the disc..!

  9. #9
    Firmware150 Guest
    AFAIK AC1 is one of the games that doesn't work at all. AC2 works fine though. Just start with 2, my friend told me you don't need to know the storyline from 1.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts