Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.


But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

  1. #1
    jimmyo88 Guest

    Games On 3.42 and beyond?

    Not sure if this has been answered but what are the chances of being able to play games past version 3.41. There are some great titles coming out (COUGH Gran Turismo COUGH) and I would love to be able to back em up.

    thanks in advance

  2. #2
    CJPC Guest
    Actually, it really depends on the game - some just need a quick edit to the SFO and they work fine, as the FW requirement is only due to when the game was mastered, vs when it was made - for instance, a game that requires 3.40, may actually work fine on 3.15.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in