Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.


But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

  1. #1
    Frogman7 Guest

    Did I brick my ps3?

    I've jailbroken my ps3 (v3.15 using PL3) a few times to try some of the homebrew apps out. I tried to install a backup manager namely Gaia 1.03.1 and it cut the video output. I waited a few minutes and turned it off. Now my ps3 won't output video, at least not through hdmi (I don't have another cable to test) and I've tried the normal methods for getting it to detect hdmi to no avail. The ps3 seems to function normally when I turn it on off and my calculator still succeeds in jailbreaking it when I try but still no video. I'm really hoping there is an easy fix because I'm really stressing out...

  2. #2
    B4rtj4h Guest
    Buy a component cable of you don't have it and try that one ??

  3. #3
    bitsbubba Guest
    Quote Originally Posted by B4rtj4h View Post
    Buy a component cable of you don't have it and try that one ??
    damn, I was going to say that.

  4. #4
    tragedy Guest
    Remove jailbreak and power cord. Plug in power cord and the red light should come on. Hold down the power button until the console beeps twice. It should reset to factory AV settings and then auto-detect the HDMI connection.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in