Results 1 to 3 of 3

Thread: Confusing PS3 Blu-ray problem help?

  1. #1
    syphonlord Guest

    Confusing PS3 Blu-ray problem help?

    Hey all looking for a bit of help if possible,I recently brought a 40 gig cechg03 from a friend of mine,it was on 3.41 firmware. Anyway i updated it to 3.55 ofw, then updated to the latest firmware and all was good, its been fine working as normal for last couple of weeks.

    Thats until today, turns on ok but for some reason it wont accept discs of any kind, just physically will not accept any discs. This also means none of my homebrew will work either, so i'm a bit gutted at the moment.

    After taking the lid off and replacing the blu-ray ribbon cable with a new one still no luck. I have also got a 60 gig ps3 that has a gpu fault, so i took the drive out of my 40 gig and put it in the 60 gig the drive will now accept discs and works fine. i also took the working 60 gig drive and put it in the 40 gig ps3 and same problem which is odd as it works fine in the 60 gig.

    I have also tried swapping the power supply in the forty gig ps3 but no luck drives will not accept discs in my 40 gig model. I don't know what to do next... have also tried different hard drive. Sorry if this is a bit confusing, anyone have any clues?

  2. #2
    Tidusnake666 Guest
    Some problems with 40 gig mainboard? Can't think of anything else particular

  3. #3
    mushy409 Guest
    Sound like you need to replace the BDROM controller board - pair the drive PCB from the 60Gb to your 40Gb then try it. If it isn't a mechanical problem, it'll be the BDROM board.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts