Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.


But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

  1. #1
    sh00ter28 Guest

    Lightbulb Assassins Creed Brotherhood Loading Screen hangs on PS3 CFW help?

    can anyone help me on my assassins creed brotherhood because after the game installation in hangs on the loading screen. my assassins creed is updated, i'm using kmeaw cfw and multiman latest version. i tried to install the patch but its not working so pls help me.

  2. #2
    Natepig Guest
    It needs to be run from internal hdd I think..

  3. #3
    madmax69 Guest
    Try going to game settings in multiman and selecting game update install any updates that it downloads. Worked for me on a couple of games that wouldn't load.

  4. #4
    sh00ter28 Guest
    its on internal its updated in 2.02 i tried making folder ASSASSIN_ISO but it didn't work, and tried patching it with pkg but it didn't work.

  5. #5
    RZA1361 Guest
    run it from internal hdd & change your cfw

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in