Page 4 of 6 FirstFirst ... 345 ... LastLast
Results 31 to 40 of 55

Thread: Retail PS3 game into a debug hdd boot game

  1. #31
    cvp Guest
    ok i have do it, but i cant find the game icon on my System. Have i do any Setting under Debug Settings? Game is on the internal HDD

  2. #32
    CJPC Guest
    Double Check the SFO to make sure it is HG.

  3. #33
    cvp Guest
    i have... i edit first file with the SFO Editing App and second file with Hex Editor! Both the same, cant find them

    ok Sorry, i see now the Game on the List, but "During startup, an error" => No Error Code.

  4. #34
    CJPC Guest
    Aha - its going to the wrong directory, intead of /dev_hdd0/game/BLUSXXXX/DATA2, the it needs to be /dev_hdd0/game/BLUSXXXX (or whatever its title id is).

  5. #35
    cvp Guest
    But the directory is on the ps3 /dev_hdd0/game/BCESXXXXXDATA2

    The Problem is: i start the PS3 in System Software Mode. The game not start. I try with Release Mode, than he start the game and make a new directory "BCESXXXXXDATA2".

    well, i delete all files again on the PS3. i Install first the debug PKG (now i have the real directory without DATA2 on the end). I copy the Files in the directory, and replace SFO and the new BOOT.BIN. Now is the game not listed i try the same procedure as yesterday

    # # #
    Has any one idea?

    To be once more direct. It is Uncharted 2 (Pal or Euro).
    The game starts not when the PS3 in the software system mode is started.
    The Screen is black and the PS3 Launches new.
    If I switch in release mode, it runs the game normally and created some files on the internal hard drive.

    The folder is not for example BCESXXXXX, it create a folder names is BCESXXXXXDATA2.

    Yesterday I try the version with the "DATA2" suffix.
    The game was registered in my games list. Only it did not allow starting, despite correct path in the Eboot.bin and the changeover of GD on HG. He gave me no error code!

    On my second I first went on trial installs the debug patch PKG in order to get the real name folder "BCESXXXXX"
    if i install the Patch debug PKG, there create a correct folder "BCESXXXXX".
    In the BCESXXXXX is a folder called "DRMDIR" where a file named is "PKG_Digest.DAT". I can not delete this folder and file!

    There, I've tried all the folders and files to delete! A folder named DRMDIR could not remove me. In this folder, a file called "PKG_Digest.DAT is". DRM seemed familiar, a protection against copying.
    So I thought I try something in the Eboot.bin file, to be exact, I was looking for DATA2!

    I found in the Eboot.bin this:

    Somehow it looks as if the Eboot.bin looking for a existent DATA2 and then gives the OK.

    can someone tell me if this is a protection? Can it be so, that does not appear the game in the games list (BCESXXXXX => without DATA2 behind it)?

  6. #36
    ncfballkid Guest
    Whenever I try to run "unfself "C:\dir\EBOOT.BIN" "C:\dir\game.elf" " it doesn't work .. like it gives me an illegal file or a file : I/O error .. any help with this guys?

  7. #37
    cvp Guest
    I think the error is that you are using a retail EBOOT. You need a debug EBOOT. The patch is in debug PKG file exists. How do you get ran on a debug patch? Either you download the section down here in PS3DebugDownload Star or you test the game and hope it gives an update from the game!

    If there is one, you can download via a link PS3Proxy server program to locate, download and extract with a PKG decompressor or, enter this command on MSYS make_package_npdrm-x PACKAGE_NAME.PKG

    To my problem back: My games are starting but the screen stays black and it does not continue

    Everything I did:
    01) I start the game, so he gave me a folder created on the PS3 (eg BLES12345)
    02) looked the same whether there is an update to the game. I take the Download link by helping from Proxserver!
    03) i rip the Game to my PC hard drive.
    04) Everything in the build BLES12345 (only one example) folder is deleted!
    05) i copy all files, what i rip befor on my PC hard drive, in the BLES12345 folder.
    06) i unpacked the Debug PKG.
    07) SFO file edited and updated by GD or DG to HG (with HxD Editor) (I take the SFO from the Original Game Disc! Not from Update! But i test is with Update file, too!)
    08) i converted EBOOT to ELF and edited. I show two examples of times two different games.

    Call of Duty - Modern Warfare 2 (BLES00686)
    only mentioned in addition: The game also has a default.self

    Call of Duty - Original file:

    Call of Duty - Edited file:

    Top Spin 3 - Original file:

    Top Spin 3 - Edited file:

    09) I now want to pack up the edited files to a PKG, I create a config.txt file only once (in the same folder where is the BLES12345 folder, of course not in BLES12345 but one before!). I give all the information purely in that file. Example:

    Call of Duty

    Content-ID = EP0001-BLES00686_00-CODMW2HDDPATCH01
    K_licensee = 0x00000000000000000000000000000000
    DRM_Type = Free
    Content_Type = GameExec
    PackageVersion = 01.00

    or for Top Spin

    Content-ID = EP0001-BLES00276_00-TOPSPIN3DPATCH01
    K_licensee = 0x00000000000000000000000000000000
    DRM_Type = Free
    Content_Type = GameExec
    PackageVersion = 01.00

    10) Now I grab the files back to a PKG file. Example:
    make_package_npdrm config.txt BLES00686
    11) The resulting file I Packe on a USB stick and install it on the PS3. He asks whether the files should be overwritten, I answer with YES. Then the game will appear in the list!
    12) Start the game => Black screen and nothing happens

    Have I done something wrong? The missing anything else? Do I have anything particular in the PS3 setting? Any debug settings?

  8. #38
    pngo Guest
    I am roughly getting to the same result as you although I am doing things in a different order.

    Here is what I do:
    -grab a debug PKG.
    -unpack the debug PKG.
    -Edit the SFO (set it to HG).
    -unfself eboot.bin and modify the resulting self. (modifying the path from /dev_bdvd... to /dev_hdd0/game/ID-of-the-game/USRDIR, tested wihout /USRDIR also).
    -re fake-sign the self with make_fself_npdrm.
    -Repackage the debug package with modified SFO and modified EBOOT.BIN specifying DRM_Type = Free
    Content_Type = GameExec
    in the package.conf file.
    -copy the modified debug package onto a usb drive and install it on the ps3 using the "Install Package" option in xmb. --> Folder /dev_hdd0/game/id-of-game is created and Game shows up in the xmb.
    -start PS3FTP server and copy the missing retail game files without overwriting the sfo and the EBOOT.BIN.

    Starting the game gives me a black screen at best, or an error (an error occured during the start operation for GOW3 for exemple).
    Can anyone comment on what is done wrong? My Debug PS3 has a faulty BD drive so it is frustrating to know there should be a way to start things directly from the hdd.


  9. #39
    ncfballkid Guest
    Thanks cvp for the reply, do you think that there is a way for us to convert a retail EBOOT to a DEBUG, using some kind of encryption .. or replacing the headers of the retail EBOOTs with the debug EBOOTs headers?

  10. #40
    cvp Guest
    the only way what i know is to downgrade the PS3 into FW 1.00 or 1.50. The Firmware 1.00 and 1.50 decrypt on the fly, and if you finish your work, you can Update your PS3 to 3.20 again.

    the same way what i do i dont know why no work. All says its easy, but we see how easy it is!

Page 4 of 6 FirstFirst ... 345 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts