Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.

But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

  1. #1
    shummyr Guest

    Question Retail to Debug packages

    is it possible to rebuild retail packages and patches to debug patches and packages?

  2. #2
    luisfg3 Guest
    No friend. It is not possible, because both have different scriptures.

  3. #3
    imtoodvs Guest
    if you can extract a retail .pkg & replace it with the debug eboot it is possible.

    i asked CJ a while back, because we have links on the debug page. me question is how would we extract them on our local machines. so now the question is how do we extract retail .pkgs on our pc hdd's?

    well, after using my brain. i just figured out how to extract retail pkg files a.k.a. PSN games. i'll give an update on if i can get it to run in a few hours.

    wrong pkg, it was the debug. trying retail now.

  4. #4
    zhixiang Guest


    You need either a retail ps3 or a debug ps3 with fw 1.60 or lower to decrypt/extract retail .pkg files. I'm wondering if a retail .pkg is installed on debug 1.50, can we somehow retrieve the extracted files on the hdd via cellftp.self?

    However, I bet those eboot.bin and .selfs are still retail-signed. Hence, you can't fself-sign them for use on debug.

  5. #5
    warpjavier Guest
    I just tried and it didn't work.

    Installed pkg in 1.50 FW, update to 3.20, load the game and game still try to get the update from internet, like the PGK was never installed, but if you look at GAME DATA, the PKG I installed in 1.50 is there.

    BTW, anybody got FIFA 10 Debug Update PKG 1.04?


    PS. Maybe with a good LV2 dump, somebody can get the key to extract Retail .pkg files and decrypt SELF files to convert them to Debug.

  6. #6
    cfwprophet Guest
    I'm pretty sure that the Keys never leave this place and will never be loaded into the RAM. So even with a Lv2 Dump you will most likely never get hands on decryptions Keys.

  7. #7
    imtoodvs Guest
    i've got a pretty interesting question (after my epic fail of trying to extract a retail pkg).

    how do we create a pkg after swapping the eboots. i mean once we figure out how to extract a retail pkg, how do we re pkg it?

    never mind, i found it, next time remind me to research before i post lol.

  8. #8
    imtoodvs Guest

    retail bd game pkg file

    i'm not sure how i did it but i made a pkg file, with the help of Shummyr (you da man). i was lazy and just copied the EBOOT.bin from the Debug update to the PS3_GAME folder & edited the PARAM.SFO file to hdd game.

    the pkg file still thinks its game data sorta, first it installs & when i start it from the xmb in the game section it goes to the " update found" screen. i see a square in the lower left corner, then the ps3 freezes.

    after i restart, i went to app_home/ps3_game & it loads from there. i hex edited my debug eboot to app_home, but im sure i i can get it to load from the xmb as a pkg with the correct settings.

    if anyone has any ideas please feel free to add some input, my brain is nuked right now. also the pkg file is 1.2 gb in case anyone cares.

  9. #9
    CJPC Guest
    If its showing as as game data, vs a game - it should be a quick fix. Open the PARAM.SFO with either a SFO editor , or a hex editor. Go down to the area where it says in text "GD" (game data) and change it to "HG" (Check out the attached image for the spot), save it, re-package it, and stick it back on the PS3 (or, use cellftp to replace it).

  10. #10
    imtoodvs Guest
    thanx CJ, dude i was sleepworking lol. the reason it showed up in app_home is because the host pc was still connected.

    the pkg file installed a 1.2 gb game data file after i tried to update with the debug update pkg. i'm editing the sfo file now, i also edited the eboot entries from bdvd to hdd0. i'll pack it up in a few & post with an update.

    Update: after i edited the the decrypted elf file & fself it , i get an error saying its not an NPDRM eboot.

    i hexed the dev_bdvd values to dev_hdd0. any idea where i went wrong?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Log in