Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.

But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

Page 1 of 2 12 Last
  1. #1
    Join Date
    Apr 2005

    Quick PS3 CoreOS Image Tool Code Released by Naehrwert

    As a follow-up to his PS3 SCETool v0.2.7 update, today PlayStation 3 homebrew developer Naehrwert has released the source code for a Quick PS3 CoreOS Image Tool via Twitter.

    Files included below are the util.h, util.cpp, types.h and main.cpp released under the GPLv2.

    Download: Quick PS3 CoreOS Image Tool Code / Quick PS3 CoreOS Image Tool (Compiled) / Quick PS3 CoreOS Image Tool Code (Mirror) / GIT

    To quote: quick coreos image tool - http://pastie.org/4003488

    [Register or Login to view code]

    [Register or Login to view code]

    [Register or Login to view code]

    [Register or Login to view code]

    More PlayStation 3 News...

  2. #2
    What's the purpose of this?

  3. #3
    kavechick1 Guest
    I wonder

  4. #4
    Ezio Guest
    It's only the source code of an unpacker for coreos, so you need to compile it. Anyway, it's not big news since there is already a similar tool between fail0verflow tools.

  5. #5
    Join Date
    Apr 2005

    PS3 Dump_Rootkey Code and Brief Guide Arrives from Naehrwert

    Following up on his Quick PS3 CoreOS Image Tool code release and recent hints, today PlayStation 3 developer Naehrwert has made available PS3 Dump_Rootkey code and a brief guide below so users can dump their own PlayStation 3 root key without Linux.

    Download: PS3 Dump_Rootkey Code / PS3 Dump_Rootkey Code (Modified and compiled by Attila for Windows using Cygwin - just provide the IP as parameter after dump_rootkey like this: dump_rootkey.exe / PS3 Resigning Tools by Attila

    Naehrwert has also confirmed that Asbestos PKG only works in 3.41. He has posted the AsbestOS and Source Code to change the offset for people to adapt it to other PS3 Firmware versions and tul compiled the ELF to an AsbestOS 3.55 PKG file.

    Additionally, jrtux compiled the AsbestOS stage2 for 3.55 with the Toolchain as naehrwert commented on Twitter, stating: "this is the modified stage2 I'm using (I guess you can change the entry and compile this yourself)"

    Build resulted in:
    • stage2_raw.bin
    • stage2_raw.elf
    • stage2_raw.lzma

    Shortly following, he also compiled the stage1 and stage2 from the original AsbestOS source and the Naehrwert AsbestOS Stage2 source resulting in:
    • stage1.elf
    • stage2_native.elf
    • stage2_raw.elf
    • stage2_raw.lzma

    Danixleet has also compiled the PS3 Dump_Rootkey and notes use includes bat file to run the dump_key and just replace with your IP followed by another compilation that assumes the user has everything ready (3.41 lv2 peek/poke) then simply drop "metldr" from console into "data".

    If not.. check your connection between PS3/router, make sure nothing is blocked or add the trusted IP's to dump_rootkey in firewall and ping must be allowed, each setup is diff.. if it fails check your firewall/router settings, it worked out of the box for me connected to the wired router.

    From voldemar_u2: Upload release build, try this one:

    From the included ReadMe file, to quote: dump_rootkey - 2012 by naehrwert


    [1] Install asbestos_ldr.g.pkg on your PS3 (a firmware with lv2 peek/poke is required to run it).
    [2] Compile the client (make sure PS3HOST in main.cpp points to your PS3).
    [3] Make sure you got your metldr in './data' as 'metldr'.
    [4] A prebuilt 'dumper' is included in './data' (dumper.elf and build.bat is
    included too if you want to change parameters).
    [5] Start asbestos_ldr on your PS3.
    [6] Start the client on your PC.
    [7] Unicorns!

    Asbestos License
    Copyright (C) 2010-2011 Hector Martin "marcan" hector AT marcansoft.com

    From cory1492: OK, I had to repackage it a couple different ways but once I got it to install it worked great. The ps3 is a slim running 3.41 hermes cfw, when the app starts the PS3 black screened, I then ran the client after editing in my PS3's IP and copying a metldr extracted from my NOR dump over to the folder as instructed), compiled under cygwin using the supplied .sh script which is really just a gcc command (I added the ULL to those two vars to fix any problems that 'int is not a long' causes under windows) and got:

    [Register or Login to view code]

    I reflashed from 4.11 dex back to hermes to test this easy way to get the RPC server going that doesn't involve installing asbestos and not only does the RPC server work a treat, I can also confirm this release dumped the same EID root key that I had obtained previously via a metldr dump.

    I'm a happy camper now, with a RPC server I can just run like an app. Sure beats going back to those old graf dongle payloads thanks naehrwert or marcan, whoever made that pkg!

    Tut: follow the info deank posted to use multiman to take a dump of your console flash, and use one of the existing tools to extract the crypted metdlr - that is all you need to do to get metldr for this.
    • Create a dump of your NOR/NAND (use multiMAN to create a .NORBIN/.NANDBIN file - USB connected as /dev_usb000 required)
    • To dump flash: mmOS->Select any file->Open in HEX viewer->[SELECT]->[START]->DUMP LV2(NO)->DUMP LV1(NO)->DUMP FLASH(YES)
    • Transfer to your PC and unpack it with norunpack.exe or cex2dex to a folder and grab "metldr" from the "asecure_loader" folder
    • Put "metldr" into the "metldrpwn" folder on your USB

    From aldostools: To get the "metldr", just dump your flash with the latest build of multiMAN: mmOS->Select any file->Open in HEX viewer->[SELECT]->[START]->DUMP LV2(NO)->DUMP LV1(NO)->DUMP FLASH(YES)

    Transfer the dumped file of the NOR or NAND flash (copied to the USB) to your PC, and use norunpack.exe:
    norunpack.exe flash.BIN extract_folder. In the extract_folder you will find the "metldr" (59KB) inside the folder "asecure_loader".

    An alternative method to extract "metldr" is using the CEX2DEX application by Gunner54. You first have to downgrade to 3.55 (DEX or CEX), to apply any flash patch using multiMAN.

    Btw, this is the fix for line 243:

    [Register or Login to view code]

    Tt was missing ULL and many (well mostly just windows/32bit ones really) compilers will treat it as a 32bit value instead of a 64bit value when you forget that.

    From KitsunePaws: To get this to compile is VS 2010 alter the header of main.cpp

    [Register or Login to view code]

    Using Dump_Rootkey on Ubuntu 12.04 Guide by jrtux:

    1- Extracting :

    [Register or Login to view code]

    2- Edit PS3HOST in main.cpp with the IP of your ps3 :

    [Register or Login to view code]

    gedit main.cpp
    edit :

    [Register or Login to view code]


    3- Compile :

    [Register or Login to view code]

    4- Extract the metldr from your flash dump and copy your metldr in 'data' dir as 'metldr' : (Get your flash dump with mmOs or memdump_0.01-FINAL and extract METLDR with CEX2DEX Application)

    5- Run :

    [Register or Login to view code]


    From his Twitter (linked above) some recent related Tweets:

    hint: pastie.org/4301209

    [Register or Login to view code]

    look ma, no linux

    Thanks to mrlowalowa for the news tip!

    From JayDee78: This is the MFW 3.41 PUP I myself used, with the patches added, use if you trust me.. Get OFW and do it yourself otherwise. Download Mirrors:

    Finally, below is a brief guide on how to do it from him as follows:

    On PC:
    • Extract the dump_rootkey.7z (or the precompiled dump_rootkey modified by Attila) to c:
    • Put the metldr in the c:\dump_rootkey\data folder (read below on how you get this file)

    • Get your flash dump with Memdump v0.01 Final, and extract the metldr with cex2dex etc, and put it in the data folder on the pc
    • Install the asbestos_ldr.g.pkg from Naehrwert's original download (dump_rootkey.7z)
    • As I was on 3.55 kmeaw and could downgrade I just got the 3.41 OFW and ran it through MFW Builder v0.2

    The settings I used:
    • Patch LV1 hypervisor
    • Patch LV2 kernel
    • Patch package installer
    • Patch application launcher

    Went into recovery on the ps3 and flashed the mfw 3.41

    Started the asbestos loader after boot up and then started dump_rootkey on my pc with the right IP and as promised: UNICORNS!

    [Register or Login to view code]

    Hope this helps some of you (at least you that CAN downgrade). From IRC:

    [Register or Login to view code]

    More PlayStation 3 News...

  6. #6
    niwakun Guest
    abestos provided on this tool only works on 3.41 Hermes, so expect that it wont work above firmware requirements.

    But hey, at least you're not going to install linux and demand for command for it. I just do hope that the abestos also works on 3.55 firmware.

  7. #7
    romantizma Guest
    We need an easy method for CEX/DEX conversion on NOR consoles please..

  8. #8
    henno Guest
    This one is not working for me. I have 3.55 CFW and built dump_rootkey.exe and started it while running the 3.41 version of the included tool on the ps3 - the 3.55 version will just exit when starting.

    I get the Info "Connecting to ..." when connecting to i tried forcing but it won't work.

    What did i do wrong? Do i need AsbestOS running for that?

  9. #9
    Luckystar Guest
    not working on 3.55 CFW

    I need AsbestOS 3.55 PKG

  10. #10
    Tidusnake666 Guest
    naehrwert's asbestos loader is for 3.41 only, tul's 3.55 port doesn't work, voldemar_u2's asbestos is also for 3.41.

    There's no point for me to downgrade to 3.41 to use it, it's simplier to install linux and wipe out data.

Page 1 of 2 12 Last

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Log in