Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.


But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

Page 11 of 15 First ... 101112 ... Last
  1. #101
    jd200 Guest

    re

    can someone kind do hex for pic 18F2550 please

  2. #102
    LioMajor Guest
    Quote Originally Posted by evilsperm View Post
    only 1 file is modified... and it has been explained by CJPC so yes I am referring you to AerialX Source cuz either way your gonna need that source. Even though I hate spoon feeding people here is the patched descriptor.h

    ~evil
    Sorry but i hate to say it, did you check the AerialX's src? Descriptor.h is not used anymore, i tested your .hex anyway.

    But mounting is NOT working. To get it working again, the Assembler file needs to be edited.

    I thought you did that.

    br,

    Lio

  3. #103
    evilsperm Guest
    LioMajor: No I didn't go through the source but I will try to work on a fix now. Thanx for the heads up.

  4. #104
    bigdaddie Guest
    You're right, I just noticed that i cannot run my backups with this port, so i guess it's not compiled correctly and maybe that's why backups and the apploader don't work... btw. running it with a Teensy2.0.

  5. #105
    LioMajor Guest
    To be exact,

    its /* */ in descriptor.h because it is now declared in payload_apploader.S

    or if you choose the other payload > payload_default.S

    br,

  6. #106
    evilsperm Guest
    correct if payload_defaut.S is used the BM will work, I am looking into payload_apploader.S to see where it needs to be patched now.

  7. #107
    dentnu Guest
    Quote Originally Posted by evilsperm View Post
    As for AT90USBKEY / AT90USBKEY2 it is exactly the same I just cloned/renamed it for the noobs.
    Thanks for clearing that up for me. You think you can plz compile me a xplain version that's patched when you get a chance plz ?

    Thanks

  8. #108
    LioMajor Guest
    Last time it worked switching " xxxx " with " bdvd " this time this is not working.

    My friend and i worked backwards from the generated .h and found also

    " /dev_ " > " usb000 " , so we tested to alter the .S string to " bdvd "

    but its not working.

  9. #109
    evilsperm Guest
    LioMajor: I am having the same issues, its not a simple 0x62, 0x64, 0x76, 0x64

    I ran into problems altering the .S as well but I'll keep pushing and see what will turn up

  10. #110
    iLLNESS Guest

    [Register or Login to view code]

    etc etc. most notably, his payload STOPS right before the normal /dev_bdvd would start.

    if anyone else wants to play around a bit and see, just do a:

    [Register or Login to view code]

    then open up the .h file. this will create aerialx's payload. to compare to the 'default' payload included with his source for comparison, edit port1_config_descriptor.S then remake the payload with the above command.

    this is all way beyond my knowledge right now and i dont see it as simple as just inserting some of the code from the default to his payload.

Page 11 of 15 First ... 101112 ... Last

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in