Sponsored Links

PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!
Sponsored Links
Sponsored Links
Results 1 to 5 of 5

  1. #1
    Senior Member shummyr's Avatar
    Sponsored Links

    Question PS3 .gp3 Creation

    Sponsored Links
    I Have the Disc Image Generator for PLAYSTATION(R)3 Command Line version 1.20 along with the corresponding genelib.dll, how do i create a *.gp3 file to use with the Image Generator?


  2. #2
    Sponsored Links
    i've got a better question, what's the command for creating a emu file. Riddle me that Batman... roflmao!

    from what i've seen, the bd_emu option can only be used with the build command, but the command only see the option as a input file, & not a sub command. can someone shine a lil light on this please?

  3. #3

    I do not know how to create *. gp3 with ps3cmd.ex3 (if possible ?), but some information.

    Open *.gp3 file with XML editor and tells: "*.gp3 file is uswell-formed according to msxml6 service"

    Open with notepad, sections are repeated whatever the game.

    [Register or Login to view code]

    Maybe I can create a template, I have no knowledge to comment on that.

    I tried some gp3 project and generates with ps3cmd.exe one bd_emu_image.emu. (but not those in the PS3)

    option 1, normal.

    -The application can not find error, and it works: http://www.ps4news.com/forums/ps3-de...de-109988.html

    -The application is a mistake and does not work.
    C:\ps3cmd>ps3cmd build kiosk_disc.gp3 image-emu.emu
    Process started.
    Loading project file.
    Verifying project.
    The following error(s) found.
    [Warn] The number of sectors is smaller than minimum(600000).
    [Error] /PS3_GAME/USRDIR/EBOOT.BIN : boot file does not contain valid version information.
    Error: Process failed. error=FFFFFFFE

    option 2, "forced"

    The application detects an error,but still generates the image.

    This requires modifying the TitleID, change by "TEST".

    Open kiosk_disc.gp3 whit notepad:
    and save.

    C:\ps3cmd>ps3cmd build kiosk_disc.gp3 kiosk.emu

    Process started.
    Loading project file.
    One or more Warning messages reported.

    Title ID is inconsistent in PS3_DISC.SFB (KIOS-12345), corrected to TEST-12345.
    Title ID is inconsistent in PS3_GAME/PARAM.SFO (KIOS-12345), corrected to TEST-12345.

    Verifying project.
    The following error(s) found.
    [Warn] The number of sectors is smaller than minimum(600000).
    [Error] /PS3_GAME/USRDIR/EBOOT.BIN : boot file does not contain valid version information.
    [Build Image]
    Format = 1
    Output = kiosk.emu
    2010-04-30 03:12:24 [Info] -- Build Process Started.
    2010-04-30 03:12:31 [Info] -- Build Process Finished. ret=00000000
    2010-04-30 03:12:31 [Info] Process successfully finished.
    Process succeeded.

    Now if you create a image.emu: kiosk.emu 257 MB (270.204.928 bytes)

    Verify image:
    C:\ps3cmd>ps3cmd verify kiosk.emu

    Process started.
    [Verify Image]
    Application Type = L-Master
    Input = (Image File) kiosk.emu

    A simple use is to run self files,if there is another simpler way to do it, of course.

    rename file.self --> EBOOT.BIN
    change original EBOOT.BIN for false EBOOT.BIN (file.self)
    Compile even error, launch with the PS3 from br-r or bd_emu.
    You can run some, like ftpd.self, mkfs.self, others not.

    gp3 files:

    gta4.gp3 http://www.ps4news.com/forums/attach...chmentid=20372
    kiosk_disc.gp3 http://www.ps4news.com/forums/attach...chmentid=20373

    And that's all.

    Attached Files Attached Files

  4. #4
    what is .gp3 files? who works?? that file do? sorry

  5. #5

    *.gp3 (generator project file) is the extension of the file where to save the compilation you created with ps3gen , so every time does not need to add files in ps3_game :icon0.png, PARAM.SFO, etc.... in USRDIR: EBOOT.BIN, etc.. that is saves your work.

    file.pg3 contains the path and file name used for a particular compilation, but it seems ps3cmd need that file already created from the compilation, either in iso format or emu, if it is not still not working.

    Not everything I say 100% certain, it is only theory that saw ps3cmd function.


Sponsored Links
Advertising - Affiliates - Contact Us - PS4 Downloads - PS4 Forums - Privacy Statement - Site Rules - Top - © 2015 PlayStation 4 News