Results 1 to 8 of 8

Thread: Guide to Use Buffalo Linkstation as Multiman PS3 Server

  1. #1
    erhanpurple Guest

    Guide to Use Buffalo Linkstation as Multiman PS3 Server

    This is how i managed to get Buffalo Linkstation ls-vl working as ps3 multiman server.

    Download ps3netsrv.c from then create the folder on you ls name whatever you want and put the file inside. ssh to you ls then;
    #ipkg install gcc
    #mkdir /opt/arm-none-linux-gnueabi/lib_disabled
    #mv /opt/arm-none-linux-gnueabi/lib/libpthread* /opt/arm-none-linux-gnueabi/lib_disabled
    #cp /lib/ /opt/arm-none-linux-gnueabi/lib/
    #cd /opt/arm-none-linux-gnueabi/lib/
    #ln -s
    #ln -s
    Enter the directory you crated and recently put the ps3netsrv.c
    #gcc -Wall -lpthread ps3netsrv.c -o ps3netsrv
    #/.ps3netsrv -d -u admin -p 38008 /mnt/disk1/share/
    After that it seems nothing hapens but it actually works. Just set the server ip and port 38008 under multiman and viola your files are there. That way you can watch movies listen music and even play games over network

    i used (/.ps3netsrv -d -u admin -p 38008 /mnt/disk1/share/bittorrent/) command to share my bittorrent download folder on Linkstation and it worked, but i only be able to see it under the file manager on Multiman cant see anything under video or picture tabs. I beleive i need to figure out seperate folder structures like aldo's gui make and move specific file types on their folders. Im planning to make some gui like aldo's that can work as a service for linkstation, like the Transmission client or Twonkyserver you will be able to reach it via web frontend and select folders you want to share, start, stop etc. Anyone think the task can be done?

    By the way i'm sharing my precompiled ps3netsrv file for Buffalo Linkstation LS-VL with you, it may be used for testing on another nases.

  2. #2
    Join Date
    Apr 2005

    Thumbs Up

    Thanks for the guide erhanpurple, I have moved it to the Guides and Tutorials section and +Rep for sharing!

  3. #3
    erhanpurple Guest
    I also made a sh script and added it to extensions.d for autostarting during the startup by doing...
    /mnt/disk1/share/ps3netsrv/ps3netsrv -d -u admin -p 38008 /mnt/disk1/share/
    chmod 755
    ln -s /mnt/disk1/share/ps3netsrv/ /etc/rc.d/extensions.d/S99ps3netsrv
    Video, Music and Retro tabs are all working now. You should create folders under your share folder like that..
    The showtime player also started to see my twonkysever, thats interesting because twonky is using completely different port. I tried to play psp cso under the retro tab and it copied automatically over network and extracted, but when i try to load it gave me usb required message. Plays music without problem, can copy files to ps3 but cant copy files from ps3 to nas.

  4. #4
    johannesswe Guest
    Hi im trying to get my linkstation 420 (ls420d) to work with latest multiman. by default multiman and showtime find my drive as a dlna server and watching movies are no problem.. but i got about 3tb of movies in .rar archives showtime plays them great from usb drive but as i cant get multiman to see the drive as a network drive i cant access anything else than music video and pictures.

    I have tried your tutorial but think i do something wrong and would need an easyer step by step guide. when you say ssh to ls do you mean i should do this with telnet?

    my network knowledge are not good. but overall an experienced user.

  5. #5
    kiffschwein Guest
    hey guys,

    does anybody know how to compile the ps3netsrv for my router where opkg is running on it? its the asus rt-n56u... maybe you could help me pls?

    its a mips based router...

  6. #6
    niwakun Guest
    tried on tomatousb with optware but alas it wont work.

  7. #7
    kiffschwein Guest
    thats cuz it needs to be compiled on our Systems!!! i never compiled a binary on my router. i've done it on Debian, w.t. build-essentials, but no build-essentials on optware, so i dunno how to do it

  8. #8
    topmusic Guest
    Great guide, have a new linkstation hacked to test it out. Tnx

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts