Page 1 of 6 12 ... LastLast
Results 1 to 10 of 51

Thread: Bypass PS3 Firmware Check Without Configuration

  1. #1
    dc740 Guest

    Smile Bypass PS3 Firmware Check Without Configuration

    I was tired of changing files to configure the DNS server on linux... and the available proxy servers had two issues:

    *they didn't let me update my PSN games (like Hustle kings)
    *and they didn't include the source code... so I didn't know what they where doing

    So I wrote a simple program (Latest Verion: PS3 Firmware Check All-In-One Remover) that uses the known DNS method to bypass the firmware check... but with one difference... you only have to configure 1 line in 1 file, and that's it... then you just run it (windows/linux/anything that supports java).

    Update: I have added the java policy file. And changed the scripts.

    also the HOW TO run he program must be updated:

    The application must be run as administrator (or root in linux) because it uses ports 53 and 80 (double check that no other application is using them!)

    If the "run" script files don't work. Open a console as administrator or root (this is VERY IMPORTANT), and run the application with the following command:
    java"./ps3java.policy" -jar ps3noupdate.jar
    It should work without any issue.

    1) HOW TO configure the ps3:
    Configure as always but in the Primary DNS selection, put the IP of the computer that is running the program

    2) HOW TO configure the program:
    Edit the file "" (inside "dnsconf" folder)
    change "" for the IP of the computer that is going to run the program (yes, it's the same as the first step)

    3) HOW TO change locale:
    By default, the program has the Mexican update file (updateFiles/updates.txt). Change it to your needs... the possible files are inside "updateFiles/alternatives" folder... choose the one you like, and copy the contents to "updateFiles/update.txt"

    Note: you can't log in to PSN if you have an EU console but you use the US update file. So change it depending on your location. You may like to try different update files, different firmware versions, etc.

    The 3.21 update files are included as demonstration only. Don't use them, since it will ask you to update your system (and that's exactly what you are trying to avoid)

    4) HOW TO Run the program:
    Windows users: Double click on run.bat
    Linux users: Run "chmod 750" the first time (you don't have to repeat this step the next time), to be able to execute it. Then run ""...
    Other OS users: Run "java -jar ps3noupdate.jar"

    There are no system required libraries, nor extra configuration. This is all you need. After that you should be able to log in successfully to the PSN.

    The attachment includes the application source code in Java too.

    I hope you like it.

  2. #2
    Join Date
    Apr 2005
    Very nice job dc740! I will add this to our How to Bypass PS3 Firmware 3.21 and Connect to PSN thread and +Rep!

  3. #3
    y2kkingboy Guest
    thank you for the awesome tool.

    i tried it a day a go but it didn't work with me. I'm running W7-U X64.

    if it is just me. I'll look somewhere else. i thought I'd just give you the heads up.


  4. #4
    dc740 Guest
    Hmm...interesting. I'm running Windows XP 32 bits.

    does it say anything when it starts?

    remember to get the ps3 configured properly. you have to run the program in your W7 machine, and use the IP of that machine in your ps3 as primary dns (NOT in the proxy settings. select "Don't use" there)

    after running the program you should be able to open
    from your web browser.
    If it's working, you should see the ps3 update file (did you remember to properly select the right update file according to your location, right?)

    And if you try to open
    you should see the same text...

    if that works, it means you ahve some kind of firewall problem.

    Let me know how it goes. I hope you can get it working

  5. #5
    y2kkingboy Guest
    actually it does not run at all.

    i'm testing my JRE to fix it up. but it seems working fine.

    and of course there is nothing on http://localhost/

  6. #6
    IanJ Guest
    I am having some problems running this. I have a fresh install of 32bit Ubuntu and java 6 jre and am running apache2.

    When I sh i get this
    Exception in thread "main" java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
    at java.lang.reflect.Method.invoke(
    at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoa der.main(
    Caused by: Permission denied
    at Method)
    at<init>(ServerImpl.ja va:70)
    at eHttpServer(
    at dc740.Main.main(
    ... 5 more
    Any idea where I'm going wrong?

  7. #7
    dc740 Guest

    Thumbs Up

    Actually yes.
    Caused by: Permission denied

    It's not the application. You can't open a socket. you MAY want to run it as administrator... or:

    If you follow the link you will see how that guy solved the problem

    Here is the same problem in Ubuntu:

    Another example:

    It's actually a problem with java, and the permissions required to create a socket. All that threads are talking about different applications. But the problem is the same. I think windows is not letting you create a listening socket in the required ports.

    Again, try to run it as administrator.

    Good luck!

  8. #8
    IanJ Guest
    Hi DC,

    I run as Sudo and still the same issue. I think my user has admin privs.


  9. #9
    y2kkingboy Guest
    sorry, but didn't work either. i tried running the bat file as an admin. but nothing happened. a dos screen for a second and nothing after.

  10. #10
    IanJ Guest
    Update def have adm privs and even added to root group with no joy.

    Y2K have you tried installing the latest JRE for windows from the sun site?

Page 1 of 6 12 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts