Page 3 of 6 FirstFirst ... 234 ... LastLast
Results 21 to 30 of 51

Thread: Bypass PS3 Firmware Check Without Configuration

  1. #21
    dc740 Guest
    I would like to update the attachment (the latest file has the updated run scripts). and the details from my last post.

    Since it's important to run the application as administrator(win) or root(linux).
    Linux won't let you open ports below 1024 if you don't... and I'm not sure but I guess windows has similar limitations, since I had bug reports from people using windows.

    The latest attachment should have those bugs fixed (if it's run as administrator)

  2. #22
    IanJ Guest
    Hi DC,
    Sorry I had to get some sleep!

    I used your new policy file (although i still see nothing in the java policy tool) and still no joy.

    I enabled the root user and redid it all in there.

    My apache install uses port 80 (although all it give me is an "it works" message on that port. Is this the problem? Can we change your code to use another port?

    Thanks again

  3. #23
    dc740 Guest
    we found the root of the problem! Finally!

    No, we can't change the port, because the PS3 is the one who needs that port. you can change the source code to run in any port, ex: 5300 instead of 53, and 8080 instead of 80... but the PS3 won't recognize it, and you won't be able to log in to your PSN account.

    I'm sorry. There is nothing I can do about the port numbers. we would need the source code of the ps3 firmware to do such a thing, but obviously we don't have it.

    You should close your apache server before starting the "all-in-one remover"... or get an cheap old machine, install a lightweight version of Linux, install java on it, and use it as your PS3 exclusive DNS server. The application doesn't need a graphical interface to run. That's one of the reasons I wrote the code. I don't like GUIs.


    Ports 53 and 80 MUST be free in order to run the application successfully. Otherwise it won't work.

  4. #24
    jabberosx Guest
    If there is enough demand for it. I can write up a small script to install this util as a service in windows. So folks dont have to expressly have it run.. I like to hide unneeded apps.

    Once they have test it tey can install it as an service and it'll run if the machine is running.

    Let me know.

  5. #25
    GrandpaHomer Guest
    Aww - works as a treat at first (well second) try - first time I've forgot to shut down my ISS Web server

    Thanks a lot for this VERY usefull and most of all portable tool. +REP to you!

    Tested on Win XP Pro SP3 so far but will test on Vista, W7 and few linuxes lying around as well and will report back.

    Can't edit do will let system to merge my double post:

    What about making this tool completely "ultimate" by not requiring the manual configuration at all (I mean setting up of the IP address)? In most cases (unless multiply network cards / IPs are active) the program should be able to detect it's own IP address and enter it in the configuration with indeed leaving the option to override / entre the address manually in case the autodetect would not work

    Also - as many people will most probably run the BAT directly from Windows rather then "manually" from DOS promt / Console you can simply add a PAUSE command at the end of the batchfile which will allow for error debug as well (e.g. DOS window will not close right away in case of error).

  6. #26
    jabberosx Guest
    Quote Originally Posted by GrandpaHomer View Post
    What about making this tool completely "ultimate" by not requiring the manual configuration at all (I mean setting up of the IP address)? In most cases (unless multiply network cards / IPs are active) the program should be able to detect it's own IP address and enter it in the configuration with indeed leaving the option to override / entre the address manually in case the autodetect would not work
    Actually already on that.. Will post the update to the tool tomorrow, Will autodetect IP and update the .db file and install and run as a service.
    Running into a snag to run it as a service currently as it can't find ./dnsconf/jnamed.conf file.. because of the way windows treat naming convention.. will recompile the src to handle that. Will come in a neat installer

    A Great app deserves a clean install

  7. #27
    dc740 Guest
    I only have on thing to say....


    I never thought my app was going to be accepted this way!
    I'm really glad people liked it, and JABEROSX, feel free to modify the tool to suit the needs of most of us.

    Just remember one thing. Some special configurations report more than one IP. That's the reasons I made the IP configuration something that must be done manually.

    You should use the same approach as mediatomb:
    It detects the IP automatically, but you can configure (using the parameters) which interface you want it to serve to...

    for example:
    My Lan:
    My Wifi:
    My virtual machine interface:

    Mediatomb used to select automatically. so I always had to start it with an options specifying I wanted to use my lan interface.

    R u working on it from Java?
    or r u using the .bat file to do that stuff?
    remember that the application should run inside linux too.

    One note for the Linux guys:
    There is no need to modify the application to start with the system. Just google how to add a startup script to your system, and you are done.
    Remember that running a command like this:
    ./ &
    Will let the app running in background and you can close the terminal console too. It's like a daemoin running in the background in windows (is not the same. I'm just trying to get to the point)

    thank you all!

    I almost forgot, the next text is for security issues only. Nothing important since most of the time this server is not run from machines with direct access to the internet. They are behind a LAN, so there is nothing to worry about:

    To run the dns server in Java, I modified a version of JNamed (a dns server that uses the dnsjava library).

    I use that, cause it works, I can modify it to my needs, and I only had to add a few lines to it to make it do what I wanted to do.

    The thing is that, for security reasons, if you are going to autodetect the IP for the internal network. You should modify the file called "jnamed.conf" (inside the dnsconf folder) and change this line "address" to "address THECORRECTIP"

    If no addresses are specified, jnamed will listen on all addresses,
    using a wildcard socket.
    I don't use that currently, cause I only open the program when I'm going to use the PS3, and the tool runs inside a LAN, so the security concerns are not that important...

    I hope it helps... also... tha java policy file should not give full access... I think it should only give socketpermissions and filepermissions (it opens the update.txt file). what do you think?

  8. #28
    dc740 Guest
    ok, I'm back. I'm pretty sure this post will be merged with my latest one... nevermind... I'll just explain what I did:

    The java policy file was not working... cause there was a missing parameter...
    the thing is, the policy only restricts java code...

    So... changes to the latest file:

    -Reduced the zip size, removing an included library that I wasn't using (I already have the source code inside the project)
    -fixed linux scripts (it still needs to be run as root, but now it's more secure)
    -fixed windows bat (Actually I just removed the unneeded java parameters, you still have to run it as administrator)
    -added a readme file with the installation instructions.

    I found ONE windows instance where I can't run it... why? I have no idea, the OS DNS is not returning the correct results. so I can't debug it. I'm currently running the app from Ubuntu, and it works great...
    I tried the older versions too, but that windows machine doesn't want to work... god knows why.

  9. #29
    jabberosx Guest
    hey DC740.. left you a message.. Can you check and reply.

  10. #30
    y2kkingboy Guest
    this is what i get when i run the bat file from dos.
    C:\Users\xxxx\Downloads\PS3NoUpdate\PS3NoUpdate>java -"./ps3java.policy" -jar ps3noupdate.jar
    Exception in thread "main" java.lang.reflect.InvocationTargetException
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoa
    Caused by: Address already in use: bind
            at Method)
            at Source)
            at Source)
            at<init>(Unknown Source)
            at<init>(Unknown Source)
            at Source)
            at dc740.Main.main(
            ... 5 more
    hope it helps..

Page 3 of 6 FirstFirst ... 234 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts