Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.


But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

Page 3 of 4 First ... 234 Last
  1. #21
    korn16ftl3 Guest
    Quote Originally Posted by Neo Cyrus View Post
    Why is there always some bs troll video involving Motor Storm? Do they actually find it funny to waste peoples time?
    i'm guessing this vid was a hoax or something.. i don't see how it couldn't work but i don't know if it did or not...

  2. #22
    TUHTA Guest
    Red Dead Redemption - 3.15 - NOT WORKING
    Modnation Racers - 3.15 - NOT WORKING
    Prince Of Persia The Forgotten Sands - 3.15 - NOT WORKING

  3. #23
    iCEQB Guest
    Quote Originally Posted by korn16ftl3 View Post
    i'm guessing this vid was a hoax or something.. i don't see how it couldn't work but i don't know if it did or not...
    No, this video is no hoax... it used to work on some FW's. It was a tiff which was able to keep the PS3 busy, while you hotswap a game which was running with one that doesn't. But Sony fixed that little glitch a long time ago.

    (BTW: They used Motor Storm because it's a launch title, so it works on every singel PS3 ).

  4. #24
    Warrorar Guest
    The European Version of Red Dead Redemption Limited Edition needs Firmware 3.30.

    greetings
    Warrorar

  5. #25
    iCEQB Guest
    Thanks to everyone so far... looks like a dead end

    I can confirm that 3D Dot Game Heroes PAL works on 3.15.
    Anyone tested Blur ?

  6. #26
    Osirisx Guest
    Quote Originally Posted by iCEQB View Post
    Thanks to everyone so far... looks like a dead end

    I can confirm that 3D Dot Game Heroes PAL works on 3.15.
    Anyone tested Blur ?
    blur is one game that i want, but not if i can't play on 3.15.

  7. #27
    iCEQB Guest
    What's going on guys? Last game to test is BLur, anyone got some news on that?

  8. #28
    Osirisx Guest
    someone here has it, they just don't want to help out, shame on you! and may your ps3 ylod next time you power up.

    i still think a wiki database would be a better idea. that way anyone can add to it, not just forum members replying to a thread like this.

  9. #29
    tragedy Guest
    I can confirm that the EU version of Blur requires 3.21 to run. No idea about the US version, but I'd imagine it's the same.

  10. #30
    Osirisx Guest
    Thanks for the update tragedy.

Page 3 of 4 First ... 234 Last

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in