Page 3 of 3 FirstFirst ... 23
Results 21 to 26 of 26

Thread: Red Faction Armageddon on PS3 CFW 3.55

  1. #21
    HAVOK7 Guest
    then is totally useless, if you start a game and you can't finish it you should not play it at all, useless fix.

  2. #22
    shadow2066 Guest
    I know, a Demo EBoot never real fixed a game!

  3. #23
    HeyManHRU Guest

    Red Faction Armageddon on Custom Firmware

    There have been a lot of rumors flying around indicating you can play this game using the Demo which happens to be 3.55 firmware on CFW.

    A french site has shared some information on how to apparently play this game on 3.55 CFW. (NOTE: If this fix turns out to be a "hoax" this thread will still remain open in case anyone wants to share any more rumors of fixes and it will serve as a discussion thread regarding this game working on 3.55 CFW.)

    To roughly tranlate: A fix has just appeared for Red Faction Armageddon.

    Some bugs were present during the career mode but other than that it all worked fine.

    What you need:

    Download the demo of the game:

    The "BLUS30585" version of the game. (Download from below):

    Download and unzip the 3.55 fix the game:


    1. Copy the files from the 3.55 fix to the full game folder (BLUS30585) and replace the files when you're prompted to.

    2. Install the demo .PKG file via "install_package_file "

    3. Put the fixed BLUS30585 folder of the game on your external hard drive formatted as FAT32 in a folder named "GAMEZ" and connect it to the PS3.

    4. Go to your favorite manager (preferably multiMAN) and load the game and it will bring you back to the XMB, run the game from the icon "App_Home_PS3_Game" (not the icon for the demo above).

  4. #24
    spunkybunny Guest
    Nope, didn't work for me. Without the demo installed it error-ed but with the demo installed it just black screens but it doesn't lock up the console and you can exit to XMB.

    If you put in a disc it comes up as "Unsupported Data" so it wont work. FAKE.

  5. #25
    HeyManHRU Guest
    Thanks for confirming man, +Rep. A user named Henry at said the game will work probably if you move the contents in the cache folder (PS3_GAME\USRDIR\build\PS3\cache) to the USRDIR (PS3_GAME\USRDIR) folder. Worth a try I guess.

    Here is what Hissatsu has to say about the 3.55 fix, to quote:

    Ellow, It also "worked" according to that Arabian (King4News) site when they "instructed" the same thing a month or two ago.

    And than they found out, yea the game starts, and you play from 6th chapter (where you start in a cave) and cant finish, because the lift isn't there (and since its using a demo EBOOT.BIN, you wont be able to save)...


  6. #26
    spunkybunny Guest
    Yep, all that about the demo was done months ago as I did it back then and it only did level 6 with no save and no way to play any other levels so it was called fake as it was useless.

    This is even worse as this doesn't even load. this is just classed as fake as all it does is change the eboot and param.sfo to redirect to the demo folder so all its going to do is play the demo and thats IF it played in the first place.

    So far there is no way to play this game and I doubt there will until someone gets around dongles or the 3.6x keys.

    When a new dev thats NOT a prick comes along and helps the scene I think I will stick to the xbox360 as EVERYTHING works as the 360 scene is awesome with awesome devs (well 1 dev, c4eva)

Page 3 of 3 FirstFirst ... 23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts