Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.

But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

  1. #3431
    twennyBensuns Guest
    Quote Originally Posted by elser1 View Post
    child of eden seems like a good game. if you're into that sort of thing.
    Takes me back to my 'Starblade' addiction days on the 3DO!! How foolish that seems now...

    Great news on the fix, even tho the PSN version has been out for a while it will be nice to save space on the internal for all the latest goodies emerging

  2. #3432
    ArgonLV Guest
    Quote Originally Posted by pr0p0sitionJOE View Post
    Nope. Not psn games Dead Space 1 and 2 are not fixed and DLC for 1 or 2 also not fixed. Games are using NPDRM which just doesnt want to get decrypted. Same as Dante Inferno game and DLC or Disney Universe DLC.
    The Dead Space 2 DLCs has been hacked, although it works on Rebug only and it requires ReactPSN. Try search for Dead Space 2 DLC pack (All DLC, including Severed) reActPSN v2.0

    Could you take a look at DLC for Star Wars: The Force Unleashed II - (USA), which is called Endor Mission Pack. It is one of few DLCs that had not been cracked properly. It is possible to activate with ReactPSN only. Could I request a proper fix/edat file for that DLC?

  3. #3433
    archangelz Guest
    Wow, more fixes already! You are awesome Joe!

    Side note to anyone. Does anyone have the SoulCalibur V Dampierre DLC they could share? The empty character slot is bugging me.

  4. #3434
    Ezio Guest
    Does anyone know if Catherine pal version has been fixed for cfw? I remember only Catherine usa version has been fixed some time ago, not the pal version ...

  5. #3435
    StanSmith Guest
    Cant you just move the patch over from the USA version to the PAL version? Most games let you do this as its only the label thats changed not the game itself.

  6. #3436
    matt101 Guest
    mass effect 3 using 3.55cfw kmeaw+multiman... tried always to get this working anybody help out plz... there has been a disc read error.the game cannot continue.please quit and restart the game... this happens when i refuse the 1.05 update.if i install 1.05 i have to upgrade to newest fw... everyother game works ...just this 1

  7. #3437
    kratosgow Guest
    pr0p0sitionJOE Can you fix AC Revelation The lost archive DLC or MGS4 trophy patch?

  8. #3438
    Ezio Guest
    I already tried it, the game loads only in english language (not my first language) but after the first video a freeze occurs and no way to go on.

  9. #3439
    digisin Guest
    Could be, just had a look at the main menu yet..

  10. #3440
    Lemonhead Guest


    Thanks a lot N0DRM! love you guys

    Lego Batman 2: DC Super Hero's: http://www.mediafire.com/?rk6e914leodt9hl

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Log in