Hey there.

So... you use an ad blocker. That's cool. Sometimes we do too.

But without ad revenue, we wouldn't even be here. And we might not be here much longer.

Please disable your ad blocker and click to continue.

Page 2 of 8 First 123 ... Last
  1. #11
    daveshooter Guest
    I have a PS3 with no BDVD and the 1st release of the 3.56 because my daughter wanted to use it on line when 3.56 was just released, as I have a number of them it was not a issue.

    She no longer uses it now so I decided to see if I could install some home-brew on a 3.56 because the ps3 is no good to me, unless I can FTP to and from it. So for some fun I thought I would have a go, nothing lost, if I fail. just another media player.

    I used PS3MFW and loaded PS3_Firmware_v3.56_USA_Update with the patch_privacy_for_rebug.tcl patch, I changed some settings like Change pup build, otheros, add new icons, patch package installer, patch application launch, secure privacy, and spoof firmware.

    It takes about 20 Min's to complete when it tells me its completed OK. The ps3 sees the update and tries to install but fails on 80 % ish saying the file is corrupt. ? lol. But it did say it was completed and seemed to sign the pup OK on the PS3_Firmware_v3.56_USA_Update I used.

    So has anyone tried this, and having the same issue, with your Games unit that doesn't play games, and the only thing its good for is watching TV catch up.?

    Thanks in advance.

    [Register or Login to view code]

  2. #12
    Join Date
    Apr 2005

    Arrow PS3MFW Builder v0.2.1 PS3 Homebrew App Update is Released

    Today PlayStation 3 developer DanyL has released an update to PS3MFW Builder bringing it to version 0.2.1 for PS3 homebrew users with some additional revisions and corresponding changes outlined below.

    Download: PS3MFW Builder v0.2.1 PS3 Homebrew App / Italian Translation XML by Martix97 / Spanish Translation XML by rubio0075 / Arabic Translation XML by silent_4 / Multi-lang Translation XML, French Translation XML, Turkish Translation XML and Multi-lang Translation XML v2 by EussNL (with the help of Atilla, Razkar and Ibocan) / Spoof_Version_3.73.tcl and Change_Cinavia_Files.tcl by propered / PS3MFW Builder v0.2.1 PS3 Homebrew App (With Spoof / Translations) by bitsbubba / PS3MFW Builder PS3 Homebrew App (With New PS3 Keys) / patched loaders.zip by zecoxao / CORE_OS_446.rar by Agrippa90 / PS3 4.46 CFW (Untested: Flasher Users Required to Test) by Habib / GIT (DanyL) / GIT (EussNL) / PS3 MFW Updates

    To quote: I start developing PS3MFW Builder 0.2.1 a few mouths ago, and since then it's just laying around my computer. It's fully working, only one function should rewritten.


    • Choose language.
    • Select Temp folder.
    • Select PS3_KEYS folder.
    • Save/Default all the settings, including selected/unselected tasks, original/modified firmware paths, theme and so on.
    • For developers: you can restart PS3MFW Builder by pressing <Shift-R>.


    I added the option to translate PS3MFW Builder to any language, including RTL, unique symbols and so on.. Thanks to eussNL for creating most of the translations.

    You can also easily create your own translation, all the text it stored in an .xml file.

    • Added the option to select multiple files using "files" option type.
    • Added the option to select directory using "directory" option type.

    Developers: The only thing should be rewritten is the "save_settings" function. The best way is to add a function in xml.tcl which will replace the text in specific node.

    Finally, from zecoxao: I have here (linked above) with me a version of mfw builder based of cfwprpht's mfw builder v3. it works, on the aspect that the auto gen tool properly generates both AC1D and Rogero 4.30 CFWs and on the aspect that the other tasks also work, but not only for 4.30. they also work for 4.46 unfortunately i can't test the pups because i don't have a flasher. if any of you wishes to give it a shot, then please take your chance.

    PS: I removed that sha1 thing, it was driving me crazy
    PPS: Some lv2 related tasks don't work on 4.46 but work on 4.30 with the auto gen task

    Just a warning. those might not actually be the correct "fake private keys"

    Here (linked above) are the patched loaders in decrypted format for 4.46. just followed Rancido's instructions:

    From Rancid-o: You have to extract manually the loaders from the LV0, decrypt them, patch the ecdsa check, encrypt the ldrs and reinsert them in LV0. Patch finded in Rebug 4.41:

    [Register or Login to view code]

    More PlayStation 3 News...

  3. #13
    technodon Guest

    PS3MFW Bulder Modifying dev_flash file error need help..

    Ok so i've found a way to remove the restrictions of the kiosk firmware by modifying some dev_flash files and replacing them with retail ones. i'm trying to build a custom firmware 4.10 kiosk/shop pup with restrictions removed that will install on a retail console but i'm getting this error in PS3MFW Builder

    [Register or Login to view code]

    any help will be appreciated. this modded firmware when/if built will be installable on a retail consoles and allow psn access and installation of retail signed packages. but it not limited like kiosk firmwares usually meaning you still have to press the combo buttons and enter a 4 digit code but you can now access playstation store, playstation home and the life with playstation thing

  4. #14
    arktos Guest
    that is a windows explorer error, if you replace files with this task. i recommend you to use another filebrowser and do not browse the folder where you replace the file, or you can close the browser after replace

  5. #15
    mushy409 Guest
    Error running script: error deleting "C:/Temp/PS3MFW-MFW/update_files/dev_flash\dev_flash\vsh": file already exists

    Change the "\" to "/" Maybe that's your problem?

  6. #16
    technodon Guest
    its working now, thanks for your help. CFW soon!

    do shop/kiosk firmwares noramlly show up on ps3 retail when you try and install them on retail? i'm sure i tried one before and it normally says (shop) firmware, anyway i'm trying to patch shop 4.10 but it always says no update data found, the only other option i have is replace each file in dev_flash 1 by 1 which is a freaking nightmre. help! thanks

  7. #17
    ps3hen Guest
    A CFW?, if you use MFW builder won't be able to install it pass FW 3.55. To see what I mean, use MFW builder with an original retail 4.10 pup and make it extract and re-pack the dev_flash without changing anything inside the dev_flash. Then when you try to install it you get the error "data is corrupted".

    Normally retail FW will not install kiosk FWs under normal circumstances. As far as I know, there is a flag inside the pup which identifies the update as retail/kiosk/debug. As this knowledge was used to patch 3.55 cfws so they would install on 3.55 kiosk FWs. I have done experimenting and found the flag offsets insides each variation of the 4.10 update.

    Update Flag Offsets:

    [Register or Login to view code]

    I am 90% certain that these are the flag offsets, as they match the ones found inside extracted .pups. But changing them for me doesn't seem to do anything for me on my un-hacked OFW4.10 PS3. But we've had differing results with our PS3s before haven't we. Perhaps they might work for you.

  8. #18
    technodon Guest
    i've created my custom 4.10 kiosk/shop firmware by using the original 4.10 firmware and swapped each file in dev_flash/vsh/module manually, found a better method of replacing the files by creating a desktop shortcut and just drag and drop with windows, got a red screen error after the first test install but then swapped /vsh/etc/ index.dat and version.txt and it works fine. anyone know the unlock code for 4.10 kiosk/shop firmware? thanks.

  9. #19
    ps3hen Guest
    Did your fw install from 4.10?

  10. #20
    technodon Guest
    no, its for 3.55 and people with downgrade capabilities

    i don't think this possible anymore, dev_flash/vsh/module/explore_plugin.sprx is the file that unlocks the xmb restrictions but if i swap it with the one from 4.10 OFW it stops my install packages working

Page 2 of 8 First 123 ... Last

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Log in