Page 35 of 102 FirstFirst ... 253435364585 ... LastLast
Results 341 to 350 of 1018

Thread: Fixing Tales of Graces F for PS3 CFW 3.55

  1. #341
    mamu Guest
    Here is the updated skitfix, full of error checking and whatnot, now you can see the reason if it crashes
    Also editing the listfile is way easier now. Here's how to use it:

    - first uncompress both us and jp rootR (if you haven't already of course)
    - put skitfix next to fps4pack (included)
    - run skitfix and set the location of your chat folders
    - it will make a "skitfixdir" folder next to the program and will check all skit files (page number is in the scs, timing and voice in chd). If it finds a different file, it tries to repack it. it will also make a more useful file list than last time

    - now start CriPackedFileMaker, select the skitfixdir folder (there should be 77+1 files), click on Build CPK file and check Try compression.
    - save it to somewhere, then unpack it (with modified script) to a folder (you can overwrite skitfixdir and delete the uncompressed files, but do not delete filesizes.txt yet).

    - open filesizes.txt, replace "your_jp_files" with the folder where your compressed files are, ready for repacking (like, jp_files). also replace "skitfixdir" with the name of the folder where you extracted your skit-cpk.
    - now copy all lines from filesizes.txt to your listfile (at line 1086 by default), be sure to overwrite and do not leave blank lines
    - repack, enjoy, post bugs

  2. #342
    donkatsu Guest
    I repacked it and looks like the game works fine (installing new data). Now if someone can tell me the earliest part of the game where skit is not aligned, I can start up a new game to test it.

    Game runs fine. I tried running from the start for about 10 min. It also loads fine from my own save too. I'm guessing the 7th skit is the one to test since the first chd file was CHT_DC007.

  3. #343
    Nogitsune Guest
    hmm.. odd. i got this error.

    > fps4pack -r skitfixdir/us skitfixdir/CHT_DC007.chd chtd
    CHD/FPS4 unpacker/repacker
    Error: fps4pack finished with error
    Internal error message: No error

    seems like fps4pack can't extract my us CHT_DC007.chd just gives "encountered a problem" error and closes.

  4. #344
    donkatsu Guest
    I did a test with the skit #7 and it worked fine. Looks like this is my final repacked cpk

    That command looks like fps4pack is having issue with repacking. Have you tried running it on the single file to see if works?

  5. #345
    Nogitsune Guest
    yeah. on single file it gives the "encountered a problem" error i mentioned and closes. just a common windows error. can you tell me the exact size of your cht_DC007? maybe mines corrupted somehow.. i don't know really.

  6. #346
    Itachi 2121E Guest
    Sorry if it sounds stupid but what changes should I make to the guide in page 19 if I have a dongle and wants to use the US game as a base?

  7. #347
    donkatsu Guest
    Well my uncompressed cht_dc007 size is 6,484kb and compressed is 1,338kb. Not sure if this will help. May want to try extracting the chat folder again to see if that was the problem.

    Itachi: the only difference is that you will need to make your own filelist. The one provided is for the Jap base. You can use tocdump2 which is attached I think on page 15 of this thread.

    Run this command on your US rootR.cpk: tocdump2 rootR.cpk -dlist up. This will create a listfile.txt Using this text file as your base, replace the lines on it with the japanese version.

  8. #348
    Nogitsune Guest
    well. i think the rootR making process should pretty much stay the same. so the only different part will be: you don't need to copy map0R and map1R . also you should use the us version and copy rootR to there obviously.

    also there has been much going on after my last guide. i did a small update a few pages later but it's still not quite up to date. i'll make a new guide from start to finish once all been solved. since there is still the issue with realigning the text in skits and the zhonecage dungeon. although i think the zhonecage dungeon problem should not happen if you use us version with a dongle.

    ps. and one more thing. there is the gui version with a guide from mamu a few pages ago. it should make things easier but if you have problems running the gui version. then my guide on page 19 + update a few pages later. should do.

  9. #349
    Itachi 2121E Guest
    Yeah I tried this but it didn't work I don't know why... Maybe I did something wrong I will try again later...

    I followed the guide with the jap as a base and it worked perfectly but now I have a dongle so I thought I will try to make a full undub but it didn't work.

  10. #350
    Nogitsune Guest
    try this: cpkcr –f rootR_US.cpk –d us_files –l rootR_mixed.txt –v (assuming rootR_US.cpk is the rootR.cpk from pure us version of the game) that is. just use rootR_US as base for your mixed rootR.cpk

    not sure if it works since i dont have a dongle but it might.

    ps. let me know what error you're getting on ps3. also be sure to test your rootR with original unpack script.

    I've done a few more tests. seems like repacking with fps4pack.exe doesn't work at all for me. always gives the same windows error.

    by the way mamu. could you attach your source codes like before, if you don't mind? it contains great educational value for a noob programmer like me.

Page 35 of 102 FirstFirst ... 253435364585 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts