I bought the VIA6421A card from newegg a few days ago and followed the textbook tutorial to mod my Samsung ms28 360. Everything seemed to be going fine until I got to the Xtreme Boot Maker part. The card wasn't listed and I didn't know what to do. After searching around online I found a few people with similar issues. I tried what they tried (removing all other IDE devices, moving the card to different slots, etc.), but nothing seemed to work.

I ran msinfo32 to see if the card was listed under SCSI or IDE, but unfortunately it wasn't. The drive shows up in the device manager under the SCSI section, but not in msinfo32.

A new beta version of XBM was released a few days ago, so I decided to try that. That version actually detects the card, but when I select it I get an error ("An error occurred while querying for WMI data: Generic failure"), and I only get the I/O number for the device and not the ID number. I tried going online and using Device ID numbers others have used with the same card, but that didn't work either. When I boot from a floppy and attempt to run SAMREAD I get the infamous "No Drive Detected" response.

Even after updating the card's drivers to 5.40a I get the same errors. I've been trying for about 3 days now, and I'm kinda out of ideas. If anyone can help, it would be MUCH appreciated. I'm almost at the point of throwing this 360 against the wall...I wonder if the warranty would cover that? Hmmm...